summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-15 17:27:23 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-15 17:59:04 +0100
commit05c8015d06d67a5ebc446ecc05149ce566b2e4cc (patch)
treeb6e1b49bdfb0989d0ba4d8b53c5ce376282bf7fd /net-news
parentdev-python/frozenlist: Bump to 1.4.1 (diff)
downloadgentoo-05c8015d06d67a5ebc446ecc05149ce566b2e4cc.tar.gz
gentoo-05c8015d06d67a5ebc446ecc05149ce566b2e4cc.tar.bz2
gentoo-05c8015d06d67a5ebc446ecc05149ce566b2e4cc.zip
net-news/rssguard: Bump to 4.6.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-news')
-rw-r--r--net-news/rssguard/Manifest1
-rw-r--r--net-news/rssguard/rssguard-4.6.3.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/net-news/rssguard/Manifest b/net-news/rssguard/Manifest
index 7cf34317f754..527827a64111 100644
--- a/net-news/rssguard/Manifest
+++ b/net-news/rssguard/Manifest
@@ -1,3 +1,4 @@
DIST rssguard-4.5.5.gh.tar.gz 23236465 BLAKE2B b650826169f42983799af04c044922b9ad0e2f6d7656df93ca1b9529a359daeb91556dfd65e9a8b7a2a97119c2f9d5b10ce6c594f6f958669f4c8c765160d7e0 SHA512 c0fd179052d26a354b6ca053725ef59ae1db6587c3bc4a92aedce36de1ecfbfd06fde387960dade22fca195fa9568e5714939113833e058dbae0d8056158d010
DIST rssguard-4.6.1.gh.tar.gz 60427864 BLAKE2B 68e72c3fe9095a4939568a49053851ad3959e772042ed975a86479e2ea429d4db02938ab069f630edcdf5704e6c8faa7e19f6aef52f3d988c0e7373f59764d22 SHA512 070c395940ffe7d93c38c7087da59be1c4af7722399d091583bdf4feea3c87fde2d28823c1bef2e9ac88db1d003dbaa483cfc09caa337f47946830ea15a35fa2
DIST rssguard-4.6.2.gh.tar.gz 60427722 BLAKE2B d83c0a520fbb72ad656862db7d2b0793f76960b69ba305985eb3c10df797b93a9e76688d16698b19219b77ceca883532bd101c011105b50946b1d2ea3a79f8eb SHA512 6518c0bda679f60d5d06b45f0aa2c569d4c9c6760042c93ea4759924756bf73edc74f821f34929a5206b610730c79b31897316ec3c02575a69133983462e0400
+DIST rssguard-4.6.3.gh.tar.gz 23360644 BLAKE2B 7906d8d38abf147dfa1938f3b847409642a971a4114cf77d99191215933c8f6204a0ba2f5815828bbb048c65e9724be1742056fee7570fc7aa388cc70ffa2f22 SHA512 3563e5df821dea6d617eeebaa8d956c0a2b43cddfef783b01079309511b394d677f84e13d8600eaa0f83c627186d5c1955db646e7758084bf162b8af0f2d8952
diff --git a/net-news/rssguard/rssguard-4.6.3.ebuild b/net-news/rssguard/rssguard-4.6.3.ebuild
new file mode 100644
index 000000000000..fd27e62a275e
--- /dev/null
+++ b/net-news/rssguard/rssguard-4.6.3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake optfeature xdg
+
+DESCRIPTION="Simple (yet powerful) news feed reader"
+HOMEPAGE="https://github.com/martinrotter/rssguard/"
+SRC_URI="
+ https://github.com/martinrotter/rssguard/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( LGPL-3 GPL-2+ ) AGPL-3+ BSD GPL-3+ MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libmpv mysql qt6 qtmultimedia +sqlite webengine"
+REQUIRED_USE="
+ || ( mysql sqlite )
+ ?? ( libmpv qtmultimedia )
+"
+
+BDEPEND="
+ !qt6? ( dev-qt/linguist-tools:5 )
+ qt6? ( dev-qt/qttools:6[linguist] )
+"
+DEPEND="
+ sys-libs/zlib:=
+ libmpv? ( media-video/mpv:= )
+ !qt6? (
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5[gstreamer]
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5[mysql?,sqlite?]
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ qtmultimedia? (
+ dev-qt/qtmultimedia:5
+ dev-qt/qtopengl:5
+ )
+ webengine? ( dev-qt/qtwebengine:5[widgets(+)] )
+ )
+ qt6? (
+ dev-qt/qtbase:6[concurrent,dbus,gui,mysql?,network,sql,sqlite?,ssl,widgets]
+ dev-qt/qtdeclarative:6
+ dev-qt/qtmultimedia:6[gstreamer]
+ dev-qt/qt5compat:6
+ media-libs/libglvnd
+ qtmultimedia? (
+ dev-qt/qtbase:6[opengl]
+ dev-qt/qtmultimedia:6
+ )
+ webengine? ( dev-qt/qtwebengine:6[widgets(+)] )
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_WITH_QT6=$(usex qt6)
+ -DNO_LITE=$(usex webengine)
+ -DREVISION_FROM_GIT=OFF
+ -DNO_UPDATE_CHECK=ON
+ -DENABLE_COMPRESSED_SITEMAP=ON
+ -DENABLE_MEDIAPLAYER_QTMULTIMEDIA=$(usex qtmultimedia)
+ -DENABLE_MEDIAPLAYER_LIBMPV=$(usex libmpv)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "ad blocking functionality" "net-libs/nodejs[npm]"
+}