summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-22 20:09:55 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-22 20:20:49 +0300
commit1762dc026e2d1fe3d22bedef33b7346b7172024e (patch)
treecb35107f63467ec3533c638d57020faa77dfe8be /net-news
parentdev-python/duecredit: mark ALLARCHES (diff)
downloadgentoo-1762dc026e2d1fe3d22bedef33b7346b7172024e.tar.gz
gentoo-1762dc026e2d1fe3d22bedef33b7346b7172024e.tar.bz2
gentoo-1762dc026e2d1fe3d22bedef33b7346b7172024e.zip
net-news/canto-daemon: enable py3.10, enable tests
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'net-news')
-rw-r--r--net-news/canto-daemon/canto-daemon-0.9.8.ebuild17
1 files changed, 14 insertions, 3 deletions
diff --git a/net-news/canto-daemon/canto-daemon-0.9.8.ebuild b/net-news/canto-daemon/canto-daemon-0.9.8.ebuild
index e9126d4bcac8..d0cff11389b5 100644
--- a/net-news/canto-daemon/canto-daemon-0.9.8.ebuild
+++ b/net-news/canto-daemon/canto-daemon-0.9.8.ebuild
@@ -4,21 +4,25 @@
EAPI=8
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="xml(+),threads(+)"
inherit distutils-r1 multilib
DESCRIPTION="Daemon part of Canto-NG RSS reader"
HOMEPAGE="https://codezen.org/canto-ng/"
SRC_URI="https://github.com/themoken/canto-next/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/canto-next-${PV}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="test"
-RDEPEND="dev-python/feedparser[${PYTHON_USEDEP}]"
+RESTRICT="test"
+PROPERTIES="test_network"
-S="${WORKDIR}/canto-next-${PV}"
+RDEPEND="dev-python/feedparser[${PYTHON_USEDEP}]"
+BDEPEND="test? ( ${RDEPEND} )"
python_prepare_all() {
# Respect libdir during plugins installation
@@ -26,3 +30,10 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
+
+python_test() {
+ local test_file
+ for test_file in tests/*; do
+ "${EPYTHON}" "${test_file}" || die "Test ${test_file} failed with ${EPYTHON}"
+ done
+}