summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna Vyalkova <cyber+gentoo@sysrq.in>2022-01-19 18:25:24 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-01-19 18:28:33 +0200
commit3deb7c21bc69924d265f184cab7fe8b71b3a3982 (patch)
treeccf8a6b07bef780ad72ddd94c2a77802ad2ea587 /net-news
parentnet-libs/canlock: add 3.3.0, drop 2b (diff)
downloadgentoo-3deb7c21bc69924d265f184cab7fe8b71b3a3982.tar.gz
gentoo-3deb7c21bc69924d265f184cab7fe8b71b3a3982.tar.bz2
gentoo-3deb7c21bc69924d265f184cab7fe8b71b3a3982.zip
net-news/rssguard: add 4.1.2, drop 3.9.2
Signed-off-by: Anna Vyalkova <cyber+gentoo@sysrq.in> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-news')
-rw-r--r--net-news/rssguard/Manifest2
-rw-r--r--net-news/rssguard/rssguard-3.9.2.ebuild50
-rw-r--r--net-news/rssguard/rssguard-4.1.2.ebuild67
3 files changed, 68 insertions, 51 deletions
diff --git a/net-news/rssguard/Manifest b/net-news/rssguard/Manifest
index e45d6f14dd1c..28e95e1fd39f 100644
--- a/net-news/rssguard/Manifest
+++ b/net-news/rssguard/Manifest
@@ -1,2 +1,2 @@
-DIST rssguard-3.9.2.tar.gz 13607587 BLAKE2B 45b3dd406e64bb13a19580255971b0d5eb1fd90d70d8559c736366af7792e7fc0627ee254dce79936ce6a179399271958b7795279a359306e345ec086081fc37 SHA512 30d2524f4ca42d903a047fe39de925268a1aac65192a8b1089b6ec0ec0a9dfef09c535fe391f750149063c06e3275b2632cc2ea2c24ded178760070abcea4958
DIST rssguard-4.0.4.tar.gz 14433147 BLAKE2B 6453d16cb440117c335d6773e675399ae4bee2d9226a2e920ffd1e10cc2d5025fc4c302357974352fad41f637aa33c3b66af2444d969f5e934d7432a16b7cb24 SHA512 8c69ec372a54e7e1ad4ff15476d2387fc84cd9d29c5031f9e5c18dcdf833781c54417101f252d23868eedc91262a9ac6446eb09104f5707b08fa92342d565481
+DIST rssguard-4.1.2.tar.gz 21716383 BLAKE2B 5c8da03cdc563799e569dd8c2170f28c5c627a0452a5d0eb325ebb7c88c352248b13624b46d26e94fe443ef1dd948bd281dedb8dcbb0546a984f56472ba0d216 SHA512 d02c6ec7ba6156b6a40e9ad929dc614b7e4aaeb8dfcfe9002e927a4c446908bcb5f299daa1fc67745fea6ebc4954e54a2c296542044a1b86ae98864d5f25bf39
diff --git a/net-news/rssguard/rssguard-3.9.2.ebuild b/net-news/rssguard/rssguard-3.9.2.ebuild
deleted file mode 100644
index 36a00b4c4bbb..000000000000
--- a/net-news/rssguard/rssguard-3.9.2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic qmake-utils xdg
-
-DESCRIPTION="Tiny RSS and Atom feed reader"
-HOMEPAGE="https://github.com/martinrotter/rssguard"
-SRC_URI="https://github.com/martinrotter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( LGPL-3 GPL-2+ ) AGPL-3+ BSD GPL-3+ MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="debug webengine"
-
-BDEPEND="dev-qt/linguist-tools:5"
-DEPEND="
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5[ssl]
- dev-qt/qtsql:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
- dev-qt/qtdeclarative:5
- webengine? ( dev-qt/qtwebengine:5[widgets] )
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
-
- sed -e 's:lib.path = $$quote($$PREFIX/lib/):lib.path = $$quote($$PREFIX/'$(get_libdir)'/):' \
- -i pri/install.pri || die
-}
-
-src_configure() {
- # CONFIG+=ltcg is needed because of https://github.com/martinrotter/rssguard/issues/156
- eqmake5 \
- CONFIG+=$(usex debug debug release) \
- $(is-flagq -flto* && echo "CONFIG+=ltcg") \
- USE_WEBENGINE=$(usex webengine true false) \
- PREFIX="${EPREFIX}"/usr \
- INSTALL_ROOT=.
-}
-
-src_install() {
- emake -j1 install INSTALL_ROOT="${D}"
-}
diff --git a/net-news/rssguard/rssguard-4.1.2.ebuild b/net-news/rssguard/rssguard-4.1.2.ebuild
new file mode 100644
index 000000000000..9dcccc8acdbd
--- /dev/null
+++ b/net-news/rssguard/rssguard-4.1.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QTMIN="5.9.0"
+inherit flag-o-matic optfeature qmake-utils xdg
+
+DESCRIPTION="Simple (yet powerful) feed reader"
+HOMEPAGE="https://github.com/martinrotter/rssguard"
+SRC_URI="https://github.com/martinrotter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( LGPL-3 GPL-2+ ) AGPL-3+ BSD GPL-3+ MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug webengine"
+
+BDEPEND=">=dev-qt/linguist-tools-${QTMIN}:5"
+DEPEND="
+ >=dev-qt/qtcore-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtmultimedia-${QTMIN}:5[gstreamer]
+ >=dev-qt/qtnetwork-${QTMIN}:5[ssl]
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ webengine? ( >=dev-qt/qtwebengine-${QTMIN}:5[widgets(+)] )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.md resources/docs/Documentation.md )
+
+src_prepare() {
+ default
+ sed -e 's:$$PREFIX/lib:$$PREFIX/'$(get_libdir)':' -i pri/install.pri || die
+}
+
+src_configure() {
+ eqmake5_args=(
+ CONFIG+=$(usex debug debug release)
+ USE_WEBENGINE=$(usex webengine true false)
+ PREFIX="${EPREFIX}"/usr
+ INSTALL_ROOT=.
+ )
+
+ # https://github.com/martinrotter/rssguard/issues/156
+ is-flagq "-flto*" && eqmake5_args+=( CONFIG+=ltcg )
+
+ eqmake5 "${eqmake5_args[@]}"
+}
+
+src_install() {
+ emake -j1 install INSTALL_ROOT="${D}"
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if use webengine; then
+ optfeature "ad blocking functionality" net-libs/nodejs[npm]
+ elog "Adblocker module requires additional npm modules to be installed:"
+ elog "npm i -g @cliqz/adblocker tldts-experimental"
+ fi
+}