summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-04-11 14:14:20 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-04-11 20:04:35 +0000
commitae1f4b64300e37b26ec1d3a49db6a3b2380b7e86 (patch)
tree359decf7a9bb5be6c3c0004cabd324b4bc215851 /net-nntp/nzbget/nzbget-17.0_pre1686.ebuild
parentnet-nntp/nzbget: fix typo in description (diff)
downloadgentoo-ae1f4b64300e37b26ec1d3a49db6a3b2380b7e86.tar.gz
gentoo-ae1f4b64300e37b26ec1d3a49db6a3b2380b7e86.tar.bz2
gentoo-ae1f4b64300e37b26ec1d3a49db6a3b2380b7e86.zip
net-nntp/nzbget: bump to 17.0_pre1686
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1234 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-nntp/nzbget/nzbget-17.0_pre1686.ebuild')
-rw-r--r--net-nntp/nzbget/nzbget-17.0_pre1686.ebuild109
1 files changed, 109 insertions, 0 deletions
diff --git a/net-nntp/nzbget/nzbget-17.0_pre1686.ebuild b/net-nntp/nzbget/nzbget-17.0_pre1686.ebuild
new file mode 100644
index 000000000000..9177f7a068f7
--- /dev/null
+++ b/net-nntp/nzbget/nzbget-17.0_pre1686.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils flag-o-matic user
+
+MY_PV=${PV/_pre/-r}
+MY_P=${PN}-${PV/_pre/-testing-r}
+
+DESCRIPTION="A command-line based binary newsgrabber supporting .nzb files"
+HOMEPAGE="http://nzbget.net/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${MY_PV}/${MY_P}-src.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="debug gnutls ncurses parcheck ssl test zlib"
+
+RDEPEND="dev-libs/libxml2
+ ncurses? ( sys-libs/ncurses:0 )
+ ssl? (
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( dev-libs/openssl:0= )
+ )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+DOCS=( ChangeLog README nzbget.conf )
+
+S=${WORKDIR}/${PN}-${PV/_pre*/-testing}
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]] && ! test-flag-CXX -std=c++14; then
+ eerror "${P} requires a C++14-capable compiler. Your current compiler"
+ eerror "does not seem to support the -std=c++14 option. Please"
+ eerror "upgrade to gcc-4.9 or an equivalent version supporting C++14."
+ die "The currently active compiler does not support -std=c++14"
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i 's:^ScriptDir=.*:ScriptDir=/usr/share/nzbget/ppscripts:' nzbget.conf || die
+
+ sed \
+ -e 's:^MainDir=.*:MainDir=/var/lib/nzbget:' \
+ -e 's:^LockFile=.*:LockFile=/run/nzbget/nzbget.pid:' \
+ -e 's:^LogFile=.*:LogFile=/var/log/nzbget/nzbget.log:' \
+ -e 's:^WebDir=.*:WebDir=/usr/share/nzbget/webui:' \
+ -e 's:^ConfigTemplate=.*:ConfigTemplate=/usr/share/nzbget/nzbget.conf:' \
+ -e 's:^DaemonUsername=.*:DaemonUsername=nzbget:' \
+ nzbget.conf > nzbgetd.conf || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable ncurses curses) \
+ $(use_enable parcheck) \
+ $(use_enable ssl tls) \
+ $(use_enable zlib gzip) \
+ $(use_enable test tests) \
+ --with-tlslib=$(usex gnutls GnuTLS OpenSSL)
+}
+
+src_test() {
+ ./nzbget --tests || die "Tests failed"
+}
+
+src_install() {
+ default
+
+ insinto /etc
+ doins nzbget.conf
+ doins nzbgetd.conf
+
+ keepdir /var/lib/nzbget/{dst,nzb,queue,tmp}
+ keepdir /var/log/nzbget
+
+ newinitd "${FILESDIR}"/nzbget.initd nzbget
+ newconfd "${FILESDIR}"/nzbget.confd nzbget
+}
+
+pkg_preinst() {
+ enewgroup nzbget
+ enewuser nzbget -1 -1 /var/lib/nzbget nzbget
+
+ fowners nzbget:nzbget /var/lib/nzbget/{dst,nzb,queue,tmp}
+ fperms 750 /var/lib/nzbget/{queue,tmp}
+ fperms 770 /var/lib/nzbget/{dst,nzb}
+
+ fowners nzbget:nzbget /var/log/nzbget
+ fperms 750 /var/log/nzbget
+
+ fowners nzbget:nzbget /etc/nzbgetd.conf
+ fperms 640 /etc/nzbgetd.conf
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog
+ elog "Please add users that you want to be able to use the system-wide"
+ elog "nzbget daemon to the nzbget group. To access the daemon run nzbget"
+ elog "with the --configfile /etc/nzbgetd.conf option."
+ elog
+ fi
+}