summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-04 03:42:58 +0000
committerSam James <sam@gentoo.org>2023-01-04 04:31:56 +0000
commit24835e8c32ec077db8f49f972e6d83ce593eeed1 (patch)
tree4da89b0895ac820b887adc55946ff43220a04c58 /net-nntp/tin
parentx11-misc/xdialog: EAPI 8 (diff)
downloadgentoo-24835e8c32ec077db8f49f972e6d83ce593eeed1.tar.gz
gentoo-24835e8c32ec077db8f49f972e6d83ce593eeed1.tar.bz2
gentoo-24835e8c32ec077db8f49f972e6d83ce593eeed1.zip
net-nntp/tin: fix configure w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-nntp/tin')
-rw-r--r--net-nntp/tin/files/tin-2.6.1-configure-clang16.patch108
-rw-r--r--net-nntp/tin/tin-2.6.1-r1.ebuild (renamed from net-nntp/tin/tin-2.6.1.ebuild)14
2 files changed, 116 insertions, 6 deletions
diff --git a/net-nntp/tin/files/tin-2.6.1-configure-clang16.patch b/net-nntp/tin/files/tin-2.6.1-configure-clang16.patch
new file mode 100644
index 000000000000..30fb937a6247
--- /dev/null
+++ b/net-nntp/tin/files/tin-2.6.1-configure-clang16.patch
@@ -0,0 +1,108 @@
+https://src.fedoraproject.org/rpms/tin/blob/bbfb5a569a97cde8d4ca95f44979070ad2f57bd0/f/tin-configure-c99.patch
+
+Add missing #include directives to pick up additional prototypes.
+Improves C99 compatibility.
+
+--- a/aclocal.m4
++++ b/aclocal.m4
+@@ -2165,8 +2165,17 @@ AC_MSG_CHECKING([if application can dump core])
+ AC_CACHE_VAL(cf_cv_corefile,[
+ AC_TRY_RUN([
+ #include <signal.h>
++#ifdef HAVE_STDLIB_H
++#include <stdlib.h>
++#endif
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#ifdef HAVE_SYS_WAIT_H
++#include <sys/wait.h>
++#endif
++#ifdef HAVE_UNISTD_H
++#include <unistd.h>
++#endif
+ int found()
+ {
+ struct stat sb;
+@@ -3319,6 +3328,9 @@ AC_DEFUN([CF_FUNC_FORK],
+ [AC_MSG_CHECKING([for fork])
+ AC_CACHE_VAL(cf_cv_func_fork,[
+ AC_TRY_RUN([
++#ifdef HAVE_UNISTD_H
++#include <unistd.h>
++#endif
+ int main()
+ {
+ if (fork() < 0)
+@@ -3465,6 +3477,9 @@ AC_MSG_CHECKING(if the system function returns usable child-status)
+ AC_CACHE_VAL(cf_cv_system_status,[
+ AC_TRY_RUN([
+ #include <stdio.h>
++#ifdef HAVE_STDLIB_H
++#include <stdlib.h>
++#endif
+ #include <signal.h>
+ #if HAVE_SYS_WAIT_H
+ #include <sys/wait.h>
+@@ -3495,7 +3510,11 @@ int main()
+ ],
+ [cf_cv_system_status=no],
+ [AC_TRY_RUN(
+- [int main() { ${cf_cv_main_return:-return}(system("exit 23") != (23 << 8)); }],
++ [
++#ifdef HAVE_STDLIB_H
++#include <stdlib.h>
++#endif
++int main() { ${cf_cv_main_return:-return}(system("exit 23") != (23 << 8)); }],
+ [cf_cv_system_status=yes],
+ [cf_cv_system_status=unknown],
+ [cf_cv_system_status=unknown])],
+--- a/configure
++++ b/configure
+@@ -26361,6 +26361,9 @@ else
+ #line 26361 "configure"
+ #include "confdefs.h"
+
++#ifdef HAVE_UNISTD_H
++#include <unistd.h>
++#endif
+ int main()
+ {
+ if (fork() < 0)
+@@ -27366,6 +27369,9 @@ else
+ #include "confdefs.h"
+
+ #include <stdio.h>
++#ifdef HAVE_STDLIB_H
++#include <stdlib.h>
++#endif
+ #include <signal.h>
+ #if HAVE_SYS_WAIT_H
+ #include <sys/wait.h>
+@@ -27417,6 +27423,9 @@ else
+ cat >"conftest.$ac_ext" <<_ACEOF
+ #line 27418 "configure"
+ #include "confdefs.h"
++#ifdef HAVE_STDLIB_H
++#include <stdlib.h>
++#endif
+ int main() { ${cf_cv_main_return:-return}(system("exit 23") != (23 << 8)); }
+ _ACEOF
+ rm -f "conftest$ac_exeext"
+@@ -27764,8 +27773,17 @@ else
+ #include "confdefs.h"
+
+ #include <signal.h>
++#ifdef HAVE_STDLIB_H
++#include <stdlib.h>
++#endif
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#ifdef HAVE_SYS_WAIT_H
++#include <sys/wait.h>
++#endif
++#ifdef HAVE_UNISTD_H
++#include <unistd.h>
++#endif
+ int found()
+ {
+ struct stat sb;
diff --git a/net-nntp/tin/tin-2.6.1.ebuild b/net-nntp/tin/tin-2.6.1-r1.ebuild
index 9a5e6df36f8c..cc1eac16cc3e 100644
--- a/net-nntp/tin/tin-2.6.1.ebuild
+++ b/net-nntp/tin/tin-2.6.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -36,10 +36,14 @@ DOCS=(
doc/{CHANGES{,.old},CREDITS,TODO,WHATSNEW,filtering}
)
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.6.1-configure-clang16.patch
+)
+
src_configure() {
tc-export AR CC RANLIB
- econf_args=(
+ local myeconfargs=(
$(use_enable cancel-locks) $(use_with cancel-locks canlock)
$(use_enable debug)
$(use_enable gpg pgp-gpg)
@@ -52,10 +56,8 @@ src_configure() {
--with-nntp-default-server="${TIN_DEFAULT_SERVER:-${NNTPSERVER:-news.gmane.io}}"
--with-pcre=/usr
--with-screen=ncursesw
- )
- # set default paths for utilities
- econf_args+=(
+ # set default paths for utilities
--with-editor="${EPREFIX}"/usr/libexec/editor
--with-gpg="${EPREFIX}"/usr/bin/gpg
--with-ispell="${EPREFIX}"/usr/bin/aspell
@@ -64,7 +66,7 @@ src_configure() {
--with-sum="${EPREFIX}"/usr/bin/sum
)
- econf "${econf_args[@]}"
+ econf "${myeconfargs[@]}"
}
src_compile() {