summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Kappus <joe@wt.gd>2023-06-08 00:08:57 -0400
committerSam James <sam@gentoo.org>2023-06-12 05:09:46 +0100
commit1b6273aaf953637f679988212279fd146f5ce77a (patch)
tree1196351c1d236a67eca2e736aa1914036e1b1ccb /net-nntp
parentapp-text/docbook-xsl-stylesheets: disable ruby27 (diff)
downloadgentoo-1b6273aaf953637f679988212279fd146f5ce77a.tar.gz
gentoo-1b6273aaf953637f679988212279fd146f5ce77a.tar.bz2
gentoo-1b6273aaf953637f679988212279fd146f5ce77a.zip
net-nntp/sabnzbd: add 4.0.2
Bug: https://bugs.gentoo.org/908032 Signed-off-by: Joe Kappus <joe@wt.gd> Closes: https://github.com/gentoo/gentoo/pull/31346 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/sabnzbd/Manifest1
-rw-r--r--net-nntp/sabnzbd/sabnzbd-4.0.2.ebuild166
2 files changed, 167 insertions, 0 deletions
diff --git a/net-nntp/sabnzbd/Manifest b/net-nntp/sabnzbd/Manifest
index c680a35133a8..9bf40591a345 100644
--- a/net-nntp/sabnzbd/Manifest
+++ b/net-nntp/sabnzbd/Manifest
@@ -1,3 +1,4 @@
DIST SABnzbd-3.7.1-src.tar.gz 5108463 BLAKE2B 5858fc5ece3948696132c64c1f4a7459319bbc604074dc78339e54e7e77353dbd141b4aad0c0cd027ac6ea1499aee0100ed7f4a1b20d0786728503eb6ffad055 SHA512 c76f74e20943196467206b5c0427421d7fe4e614855c477a045d06854c5247c13056ce9055d82b5f0c6391a046dc3c65c577e50fc30646c8f2290df4bada4fb9
DIST SABnzbd-3.7.2-src.tar.gz 5108729 BLAKE2B 8c279663f5395b613e7122e349971994f98b3ef22d23f18083b64864bc6e27653ca525a59226d2af5dc10a8cfd7509014c60e5b322137239e6eec03239746768 SHA512 d5fa9dc1a3114bd0806e580a170552fb8821e375790c2b95c7add4b25a4ceabad24111c4d6a9c12bcc9447dc0a5cbf6a8595e0142a74ee9d161849a9e55609e9
DIST SABnzbd-4.0.1-src.tar.gz 5079799 BLAKE2B 5020b0f906bdb87b5eb287fee321fc765ad959754f3293395275930deab7baf8533f575993ff5c02cfbc646745eefee1ca4aa8cbeaba94d15c43a4dc8d5c78e6 SHA512 98958e9c6b35118781fec28853f1b9a0405bd262aba734af22c0bb64d5d25899c49bcb3aac4f449baccc629da6739ab1c4a33f5947c61646b35788d9e971e9cb
+DIST SABnzbd-4.0.2-src.tar.gz 5081392 BLAKE2B 1740aad2a5b248b22dda42cb22b740c54d792e726bec27c832ffc8919d863f1cec26aaff4e789e0dd8ae3647332f9aa9b26ca5422ce7baf955f8c37ac8c22142 SHA512 2f0d2297449ecbf8ddbb7a571f6dfa6717c5b118389a67e46072f25daca16d2983827e8f17e1cf016fbf2985fa5594dbafc62cf13601607dc2b4d9849098982b
diff --git a/net-nntp/sabnzbd/sabnzbd-4.0.2.ebuild b/net-nntp/sabnzbd/sabnzbd-4.0.2.ebuild
new file mode 100644
index 000000000000..6a9a1b596a0e
--- /dev/null
+++ b/net-nntp/sabnzbd/sabnzbd-4.0.2.ebuild
@@ -0,0 +1,166 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit optfeature python-single-r1 systemd
+
+MY_PV="${PV/_alpha/Alpha}"
+MY_PV="${MY_PV/_beta/Beta}"
+MY_PV="${MY_PV/_rc/RC}"
+
+MY_P="${PN/sab/SAB}-${MY_PV}"
+
+DESCRIPTION="Binary newsgrabber with web-interface"
+HOMEPAGE="https://sabnzbd.org/"
+SRC_URI="https://github.com/sabnzbd/sabnzbd/releases/download/${MY_PV}/${MY_P}-src.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+# Sabnzbd is GPL-2 but bundles software with the following licenses.
+LICENSE="GPL-2 BSD LGPL-2 MIT BSD-1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ acct-user/sabnzbd
+ acct-group/sabnzbd
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/cheetah3[${PYTHON_USEDEP}]
+ dev-python/cherrypy[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/feedparser-6.0.10[${PYTHON_USEDEP}]
+ >=dev-python/guessit-3.7.1[${PYTHON_USEDEP}]
+ dev-python/notify2[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ dev-python/puremagic[${PYTHON_USEDEP}]
+ ~dev-python/sabyenc-7.0.2[${PYTHON_USEDEP}]
+ ')
+ test? ( $(python_gen_cond_dep '
+ dev-python/tavalidate[${PYTHON_USEDEP}]
+ >=dev-python/tavern-2[${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ >=app-arch/par2cmdline-0.8
+ net-misc/wget
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.5.0[${PYTHON_USEDEP}]
+ dev-python/pkginfo[${PYTHON_USEDEP}]
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ ')
+ app-arch/p7zip
+ app-arch/unrar
+ app-arch/unzip
+ www-apps/chromedriver-bin
+ )
+"
+
+src_test() {
+ local EPYTEST_IGNORE=(
+ # network sandbox
+ tests/test_getipaddress.py
+ tests/test_rss.py
+ tests/test_urlgrabber.py
+ tests/test_utils/test_happyeyeballs.py
+ tests/test_utils/test_internetspeed.py
+ )
+ local EPYTEST_DESELECT=(
+ # network sandbox
+ 'tests/test_cfg.py::TestValidators::test_validate_host'
+ 'tests/test_consistency.py::TestWiki'
+ 'tests/test_newswrapper.py::TestNewsWrapper'
+ # Doesn't work, complains mocker missing even when pytest-mock installed
+ 'tests/test_dirscanner.py::TestDirScanner'
+ # Just plain fails
+ 'tests/test_newsunpack.py::TestPar2Repair::test_basic'
+ # Chromedriver tests don't want to behave in portage
+ 'tests/test_functional_config.py::TestBasicPages::test_base_pages'
+ 'tests/test_functional_config.py::TestBasicPages::test_base_submit_pages'
+ 'tests/test_functional_config.py::TestConfigLogin::test_login'
+ 'tests/test_functional_config.py::TestConfigCategories::test_page'
+ 'tests/test_functional_config.py::TestConfigRSS::test_rss_basic_flow'
+ 'tests/test_functional_config.py::TestConfigServers::test_add_and_remove_server'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_basic_rar5'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_zip'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_7zip'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_passworded'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_fully_obfuscated'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_unicode_rar'
+ 'tests/test_functional_misc.py::TestShowLogging::test_showlog'
+ 'tests/test_functional_misc.py::TestQueueRepair::test_queue_repair'
+ 'tests/test_functional_misc.py::TestDaemonizing::test_daemonizing'
+ 'tests/test_functional_sorting.py::TestDownloadSorting'
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=tavern._core.pytest
+ epytest -s
+}
+
+src_install() {
+ local d
+ for d in email icons interfaces locale po sabnzbd scripts tools; do
+ insinto /usr/share/${PN}/${d}
+ doins -r ${d}/*
+ done
+
+ exeinto /usr/share/${PN}
+ doexe SABnzbd.py
+
+ python_fix_shebang "${ED}"/usr/share/${PN}
+ python_optimize "${ED}"/usr/share/${PN}
+
+ newinitd "${FILESDIR}"/${PN}-r1.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ diropts -o ${PN} -g ${PN}
+ dodir /etc/${PN}
+ keepdir /var/log/${PN}
+
+ insinto "/etc/${PN}"
+ insopts -m 0600 -o "${PN}" -g "${PN}"
+ newins "${FILESDIR}"/${PN}-r1.ini ${PN}.ini
+
+ dodoc ISSUES.txt README.mkd
+
+ systemd_newunit "${FILESDIR}"/sabnzbd_at.service 'sabnzbd@.service'
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ einfo "Default directory: /var/lib/${PN}"
+ einfo
+ einfo "To add a user to the sabnzbd group so it can edit SABnzbd+ files, run:"
+ einfo
+ einfo " usermod -a -G sabnzbd <user>"
+ einfo
+ einfo "By default, SABnzbd will listen on TCP port 8080."
+ fi
+
+ optfeature "7z archive support" app-arch/p7zip
+ optfeature "rar archive support" app-arch/unrar app-arch/rar
+ optfeature "zip archive support" app-arch/unzip
+}