summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2021-09-09 14:20:26 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-09-09 14:24:42 +0300
commit33fde56460066967775cd4f48187564d79ba17ad (patch)
tree7fcfaf0e805466ea49e873d44ecf90d07e2c576f /net-nntp
parentnet-nntp/slrn: revbump to support canlock v3.x (diff)
downloadgentoo-33fde56460066967775cd4f48187564d79ba17ad.tar.gz
gentoo-33fde56460066967775cd4f48187564d79ba17ad.tar.bz2
gentoo-33fde56460066967775cd4f48187564d79ba17ad.zip
net-nntp/tin: add 2.6.0
* set correct LICENSE (main code is licensed under 3-clause BSD, only metamutt script is GPL) * remove "doc" USE flag as unnecessary * remove "etiquette" USE flag (can be toggled in tinrc) * remove "ipv6" USE flag (no external deps) * remove "unicode" USE flag (tin 2.6 builds with ncursesw only) * remove "mime" and "spell" USE flags (optional runtime functionality) * depend unconditionally on dev-libs/icu * depend on virtual/libintl instead of gettext (tarball already has .gmo files) * add yacc build dependency * unbundle libcanlock * gmane.org -> gmane.io * install localized manpages * do not remove mbox.5 and mmdf.5 manpages (e-file reports no collisions) Couldn't reproduce bug #725226 Bug: https://bugs.gentoo.org/725226 Closes: https://bugs.gentoo.org/550620 Signed-off-by: Anna Vyalkova <cyber+gentoo@sysrq.in> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/tin/Manifest1
-rw-r--r--net-nntp/tin/metadata.xml6
-rw-r--r--net-nntp/tin/tin-2.4.5-r1.ebuild2
-rw-r--r--net-nntp/tin/tin-2.6.0.ebuild87
4 files changed, 92 insertions, 4 deletions
diff --git a/net-nntp/tin/Manifest b/net-nntp/tin/Manifest
index 339871627b93..001b34ab27e8 100644
--- a/net-nntp/tin/Manifest
+++ b/net-nntp/tin/Manifest
@@ -1 +1,2 @@
DIST tin-2.4.5.tar.xz 1559164 BLAKE2B 4efea88c7f76aef91a848c9ed5d82efac640360e41c515015d406e84ed5ce639bbcd17eff29939312ebf83adb8bb84bc7a4f04833cd7cc0781f92b377a0cb31f SHA512 4ec1c4990ce8d9a46204c0064f19c5c2b99848201c37562f8df76de5be84fdd2bcd35cbc3e9f20233f636522e086ac031a5a9cb65bd22a53eda619dcce86adbc
+DIST tin-2.6.0.tar.xz 1575564 BLAKE2B 2f42261457b359c63461953335f25de21fd3e54b3730b5db39daf0f25929e8c39a4c89be4d558bed9ce81801d2e3cad3d163c1827d2f3064144d8b2bf34ae645 SHA512 d843bd313fd144fbb5f4c40e3f0f776cab3a974494adc7004ee265235ab538dde520bc72c956d5a8517225fdb50e754b444f25bd3b661ddf51ff9e4135904862
diff --git a/net-nntp/tin/metadata.xml b/net-nntp/tin/metadata.xml
index 54d0b1a01589..bd47f200bdb0 100644
--- a/net-nntp/tin/metadata.xml
+++ b/net-nntp/tin/metadata.xml
@@ -3,9 +3,9 @@
<pkgmetadata>
<!-- maintainer-needed -->
<use>
-<flag name="cancel-locks">Enable Cancel-Lock header functionality (also enables USE=evil)</flag>
+<flag name="cancel-locks">Enable Cancel-Lock header functionality</flag>
<flag name="gpg">Enable <pkg>app-crypt/gnupg</pkg> support</flag>
-<flag name="etiquette">Enable the display off posting etiquettes</flag>
-<flag name="mime">Add MIME support</flag>
+<flag name="etiquette" restrict="&lt;net-nntp/tin-2.6.0">Enable the display off posting etiquettes</flag>
+<flag name="mime" restrict="&lt;net-nntp/tin-2.6.0">Add MIME support</flag>
</use>
</pkgmetadata>
diff --git a/net-nntp/tin/tin-2.4.5-r1.ebuild b/net-nntp/tin/tin-2.4.5-r1.ebuild
index d9022f05e519..a5435105bbfb 100644
--- a/net-nntp/tin/tin-2.4.5-r1.ebuild
+++ b/net-nntp/tin/tin-2.4.5-r1.ebuild
@@ -9,7 +9,7 @@ DESCRIPTION="A threaded NNTP and spool based UseNet newsreader"
HOMEPAGE="http://www.tin.org/"
SRC_URI="ftp://ftp.tin.org/pub/news/clients/tin/stable/${P}.tar.xz"
-LICENSE="GPL-2"
+LICENSE="BSD GPL-2+"
SLOT="0"
KEYWORDS="amd64 arm ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="cancel-locks debug doc +etiquette gpg idn ipv6 mime nls sasl socks5 spell unicode"
diff --git a/net-nntp/tin/tin-2.6.0.ebuild b/net-nntp/tin/tin-2.6.0.ebuild
new file mode 100644
index 000000000000..2f0923bd8d95
--- /dev/null
+++ b/net-nntp/tin/tin-2.6.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature toolchain-funcs
+
+DESCRIPTION="A threaded NNTP and spool based UseNet newsreader"
+HOMEPAGE="http://www.tin.org/"
+SRC_URI="ftp://ftp.tin.org/pub/news/clients/tin/stable/${P}.tar.xz"
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="cancel-locks debug gpg nls sasl socks5"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/libpcre:3
+ dev-libs/uulib
+ sys-libs/ncurses:=[unicode(+)]
+ cancel-locks? ( >=net-libs/canlock-3.0:= )
+ gpg? ( app-crypt/gnupg )
+ nls? ( virtual/libintl )
+ sasl? ( virtual/gsasl )
+ socks5? ( net-proxy/dante )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ virtual/yacc
+"
+
+DOCS=(
+ README{,.MAC,.WIN}
+ doc/{CHANGES{,.old},CREDITS,TODO,WHATSNEW,filtering}
+)
+
+src_configure() {
+ tc-export AR CC RANLIB
+
+ econf_args=(
+ $(use_enable cancel-locks) $(use_with cancel-locks canlock)
+ $(use_enable debug)
+ $(use_enable gpg pgp-gpg)
+ $(use_enable nls)
+ $(use_with socks5 socks) $(use_with socks5)
+ --disable-mime-strict-charset
+ --enable-nntp-only
+ --enable-prototypes
+ --with-coffee
+ --with-nntp-default-server="${TIN_DEFAULT_SERVER:-${NNTPSERVER:-news.gmane.io}}"
+ --with-pcre=/usr
+ --with-screen=ncursesw
+ )
+
+ # set default paths for utilities
+ econf_args+=(
+ --with-editor="${EPREFIX}"/usr/libexec/editor
+ --with-gpg="${EPREFIX}"/usr/bin/gpg
+ --with-ispell="${EPREFIX}"/usr/bin/aspell
+ --with-mailer="${EPREFIX}"/bin/mail
+ --with-metamail="${EPREFIX}"/usr/bin/metamail
+ --with-sum="${EPREFIX}"/usr/bin/sum
+ )
+
+ econf "${econf_args[@]}"
+}
+
+src_compile() {
+ # To build from the root dir you have to call `make build`, not just
+ # `make`.
+ emake build
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install_sysdefs
+ emake -C src DESTDIR="${D}" install_nls_man
+
+ dodoc doc/{*.sample,*.txt}
+}
+
+pkg_postinst() {
+ optfeature "view MIME articles" net-mail/metamail
+ optfeature "spell checker support" app-text/aspell
+}