summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-11-07 11:42:18 +0100
committerDavid Seifert <soap@gentoo.org>2017-11-07 14:48:48 +0100
commitefed9d385d28cb6656c310bd60f842cb120617bc (patch)
tree428b7780750bb92c663d071f1f7abe803d67f92c /net-p2p/airdcpp-webclient/airdcpp-webclient-2.2.1.ebuild
parentsys-apps/dbus: Added sys-devel/autoconf-archive to DEPEND. (diff)
downloadgentoo-efed9d385d28cb6656c310bd60f842cb120617bc.tar.gz
gentoo-efed9d385d28cb6656c310bd60f842cb120617bc.tar.bz2
gentoo-efed9d385d28cb6656c310bd60f842cb120617bc.zip
net-p2p/airdcpp-webclient: bump to 2.2.1, fixes a remote crash
See https://airdcpp-web.github.io/2017/10/13/version-2.2.1.html Package-Manager: Portage-2.3.13, Repoman-2.3.4 Closes: https://github.com/gentoo/gentoo/pull/6143
Diffstat (limited to 'net-p2p/airdcpp-webclient/airdcpp-webclient-2.2.1.ebuild')
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-2.2.1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-2.2.1.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.2.1.ebuild
new file mode 100644
index 000000000000..fd8f46fe630b
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.2.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+
+inherit cmake-utils python-any-r1 user
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://airdcpp-web.github.io/"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="nat-pmp +tbb +webui"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost:=
+ dev-libs/geoip
+ dev-libs/leveldb:=
+ dev-libs/openssl:0=[-bindist]
+ net-libs/miniupnpc:=
+ sys-libs/zlib:=
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp:= )
+ tbb? ( dev-cpp/tbb:= )
+"
+DEPEND="
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+ ${RDEPEND}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ enewgroup airdcppd
+ enewuser airdcppd -1 -1 /var/lib/airdcppd airdcppd
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_WEB_UI=OFF
+ -DENABLE_NATPMP=$(usex nat-pmp)
+ -DENABLE_TBB=$(usex tbb)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ keepdir /var/lib/airdcppd
+ fowners airdcppd:airdcppd /var/lib/airdcppd
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}