summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2022-11-05 20:12:03 +0100
committerLouis Sautier <sbraz@gentoo.org>2022-11-05 20:35:53 +0100
commit3c87eae224d451e0433cd4338773f945fb879277 (patch)
tree46330704a7ace35f600ecfd319ff51f7b17bf93a /net-p2p/airdcpp-webclient
parentgames-simulation/openrct2: drop lightfx from metadata (diff)
downloadgentoo-3c87eae224d451e0433cd4338773f945fb879277.tar.gz
gentoo-3c87eae224d451e0433cd4338773f945fb879277.tar.bz2
gentoo-3c87eae224d451e0433cd4338773f945fb879277.zip
net-p2p/airdcpp-webclient: fix build with strict flags, add Py3.11
Closes: https://bugs.gentoo.org/861839 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'net-p2p/airdcpp-webclient')
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-2.11.2.ebuild6
-rw-r--r--net-p2p/airdcpp-webclient/files/airdcpp-webclient-2.11.2-fix-odr.patch22
2 files changed, 27 insertions, 1 deletions
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-2.11.2.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.11.2.ebuild
index 8b834ebeb9f1..76af45cb877b 100644
--- a/net-p2p/airdcpp-webclient/airdcpp-webclient-2.11.2.ebuild
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.11.2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
inherit cmake python-any-r1 systemd
@@ -38,6 +38,10 @@ BDEPEND="
"
PDEPEND="webui? ( www-apps/airdcpp-webui )"
+PATCHES=(
+ "${FILESDIR}/${P}-fix-odr.patch"
+)
+
src_configure() {
local mycmakeargs=(
-DENABLE_NATPMP=$(usex nat-pmp)
diff --git a/net-p2p/airdcpp-webclient/files/airdcpp-webclient-2.11.2-fix-odr.patch b/net-p2p/airdcpp-webclient/files/airdcpp-webclient-2.11.2-fix-odr.patch
new file mode 100644
index 000000000000..e44365ca1bd2
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/files/airdcpp-webclient-2.11.2-fix-odr.patch
@@ -0,0 +1,22 @@
+From 5f12f803c2fc0450111152e2ea5f649ed92f4b7f Mon Sep 17 00:00:00 2001
+From: maksis <maksis@adrenaline-network.com>
+Date: Thu, 13 Oct 2022 22:05:35 +0300
+Subject: [PATCH] Build: define the HAVE_POSIX_FADVISE flag correctly
+
+Fixes https://github.com/airdcpp-web/airdcpp-webclient/issues/425
+---
+ airdcpp-core/CMakeLists.txt | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+--- a/airdcpp-core/CMakeLists.txt
++++ b/airdcpp-core/CMakeLists.txt
+@@ -75,8 +75,7 @@ if (HAVE_MNTENT_H)
+ endif (HAVE_MNTENT_H)
+
+ if (HAVE_POSIX_FADVISE)
+- set_property(SOURCE ${PROJECT_SOURCE_DIR}/airdcpp/File.cpp PROPERTY COMPILE_DEFINITIONS HAVE_POSIX_FADVISE APPEND)
+- set_property(SOURCE ${PROJECT_SOURCE_DIR}/airdcpp/File.h PROPERTY COMPILE_DEFINITIONS HAVE_POSIX_FADVISE APPEND)
++ add_definitions (-DHAVE_POSIX_FADVISE)
+ endif (HAVE_POSIX_FADVISE)
+
+