summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-04-11 09:48:44 -0400
committerCraig Andrews <candrews@gentoo.org>2018-04-11 09:51:45 -0400
commit5741530e52844ae9e2267a2b237289b17401f84f (patch)
treecd6489576770beb8b58d956af21765cbcdf29451 /net-p2p/cpuminer-opt/cpuminer-opt-3.8.7.1.ebuild
parentpackage.use.mask: Masked "ldap" USE flag for >=openssh-7.7_p1 (diff)
downloadgentoo-5741530e52844ae9e2267a2b237289b17401f84f.tar.gz
gentoo-5741530e52844ae9e2267a2b237289b17401f84f.tar.bz2
gentoo-5741530e52844ae9e2267a2b237289b17401f84f.zip
net-p2p/cpuminer-opt: 3.8.7.1 version bump
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'net-p2p/cpuminer-opt/cpuminer-opt-3.8.7.1.ebuild')
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.8.7.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.8.7.1.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.7.1.ebuild
new file mode 100644
index 000000000000..a1f4a660f6b9
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.7.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ curl? ( >=net-misc/curl-7.15[ssl] )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto $(use_with curl)
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}