summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPPed72 <paolo.pedroni@iol.it>2019-01-23 11:58:20 +0100
committerCraig Andrews <candrews@gentoo.org>2019-01-24 18:22:22 -0500
commitdd83699d620548c1e6fe2cd14cd5f51058b1dac5 (patch)
tree273b05e17441cb87c519a6de2fd527fc55e8c586 /net-p2p/deluge/deluge-1.3.9999.ebuild
parentdev-libs/appstream: Fix build with USE !test (diff)
downloadgentoo-dd83699d620548c1e6fe2cd14cd5f51058b1dac5.tar.gz
gentoo-dd83699d620548c1e6fe2cd14cd5f51058b1dac5.tar.bz2
gentoo-dd83699d620548c1e6fe2cd14cd5f51058b1dac5.zip
net-p2p/deluge: restrict libtorrent-rasterbar dependency
net-libs/libtorrent-rasterbar-1.2 removed several deprecated functions needed by net-p2p deluge. We thus restrict the dependency to be <net-libs/libtorrent-rasterbar-1.2 Also a few cleanups already discussed for deluge-9999 Closes: https://bugs.gentoo.org/676056 Signed-off-by: Paolo Pedroni <paolo.pedroni@iol.it> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10892 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p/deluge/deluge-1.3.9999.ebuild')
-rw-r--r--net-p2p/deluge/deluge-1.3.9999.ebuild19
1 files changed, 5 insertions, 14 deletions
diff --git a/net-p2p/deluge/deluge-1.3.9999.ebuild b/net-p2p/deluge/deluge-1.3.9999.ebuild
index a32833a4f9f9..5abf8ffb3d04 100644
--- a/net-p2p/deluge/deluge-1.3.9999.ebuild
+++ b/net-p2p/deluge/deluge-1.3.9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
PYTHON_COMPAT=( python2_7 )
DISTUTILS_SINGLE_IMPL=1
-PLOCALES="af ar ast be bg bn bs ca cs cy da de el en_AU en_CA en_GB eo es et eu fa fi fo fr fy ga gl he hi hr hu id is it iu ja ka kk km kn ko ku ky la lb lt lv mk ml ms nap nb nds nl nn oc pl pms pt pt_BR ro ru si sk sl sr sv ta te th tl tlh tr uk ur vi zh_CN zh_HK zh_TW"
-inherit distutils-r1 eutils systemd user l10n
+inherit distutils-r1 systemd user
DESCRIPTION="BitTorrent client with a client/server model"
HOMEPAGE="https://deluge-torrent.org/"
@@ -34,11 +33,10 @@ PATCHES=(
"${FILESDIR}/${PN}-1.3.5-disable_libtorrent_internal_copy.patch"
)
-CDEPEND="net-libs/libtorrent-rasterbar[python,${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}
+DEPEND="<net-libs/libtorrent-rasterbar-1.2[python,${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
dev-util/intltool"
-RDEPEND="${CDEPEND}
+RDEPEND="<net-libs/libtorrent-rasterbar-1.2[python,${PYTHON_USEDEP}]
dev-python/chardet[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
dev-python/pyxdg[${PYTHON_USEDEP}]
@@ -71,13 +69,6 @@ python_prepare_all() {
)
sed -i "${args[@]}" -- 'deluge/core/preferencesmanager.py' || die
- local loc_dir="${S}/deluge/i18n"
- l10n_find_plocales_changes "${loc_dir}" "" ".po"
- rm_loc() {
- rm -vf "${loc_dir}/${1}.po" || die
- }
- l10n_for_each_disabled_locale_do rm_loc
-
distutils-r1_python_prepare_all
}