summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-15 08:39:10 +0100
committerSam James <sam@gentoo.org>2022-07-15 08:39:36 +0100
commit0197e44b213e11b93bdea29eaed0064c073236ea (patch)
tree97a742f015a61beb3b29b71d98337d1b08a8a157 /net-p2p/ed2k_hash
parentdev-python/dj-search-url: Mark ALLARCHES (diff)
downloadgentoo-0197e44b213e11b93bdea29eaed0064c073236ea.tar.gz
gentoo-0197e44b213e11b93bdea29eaed0064c073236ea.tar.bz2
gentoo-0197e44b213e11b93bdea29eaed0064c073236ea.zip
net-p2p/ed2k_hash: EAPI 8
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-p2p/ed2k_hash')
-rw-r--r--net-p2p/ed2k_hash/ed2k_hash-0.4.0-r3.ebuild (renamed from net-p2p/ed2k_hash/ed2k_hash-0.4.0-r2.ebuild)22
-rw-r--r--net-p2p/ed2k_hash/files/ed2k_64bit.patch4
-rw-r--r--net-p2p/ed2k_hash/files/ed2k_hash-0.4.0-missing-includes.patch20
3 files changed, 34 insertions, 12 deletions
diff --git a/net-p2p/ed2k_hash/ed2k_hash-0.4.0-r2.ebuild b/net-p2p/ed2k_hash/ed2k_hash-0.4.0-r3.ebuild
index d415e2ec2ecd..2f50faf76f65 100644
--- a/net-p2p/ed2k_hash/ed2k_hash-0.4.0-r2.ebuild
+++ b/net-p2p/ed2k_hash/ed2k_hash-0.4.0-r3.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
#inherit flag-o-matic
DESCRIPTION="Tool for generating eDonkey2000 links"
HOMEPAGE="http://ed2k-tools.sourceforge.net/ed2k_hash.shtml"
-RESTRICT="mirror"
SRC_URI="mirror://sourceforge/ed2k-tools/${P}.tar.gz"
LICENSE="GPL-2"
@@ -15,19 +14,22 @@ SLOT="0"
KEYWORDS="amd64 ppc ~sparc x86"
IUSE="" # fltk support is broken, bug #359643
-DEPEND=""
-RDEPEND=""
+RESTRICT="mirror"
+
#DEPEND="fltk? ( x11-libs/fltk:1 )"
-PATCHES=( "${FILESDIR}/ed2k_64bit.patch" )
+PATCHES=(
+ "${FILESDIR}/ed2k_64bit.patch"
+ "${FILESDIR}/${PN}-0.4.0-missing-includes.patch"
+)
src_configure() {
-# if use fltk; then
-# append-ldflags "$(fltk-config --ldflags)"
-# export CPPFLAGS="$(fltk-config --cxxflags)"
-# else
+ #if use fltk; then
+ # append-ldflags "$(fltk-config --ldflags)"
+ # export CPPFLAGS="$(fltk-config --cxxflags)"
+ #else
export ac_cv_lib_fltk_main='no'
-# fi
+ #fi
econf
}
diff --git a/net-p2p/ed2k_hash/files/ed2k_64bit.patch b/net-p2p/ed2k_hash/files/ed2k_64bit.patch
index 3523b1febecd..2f1520e137ec 100644
--- a/net-p2p/ed2k_hash/files/ed2k_64bit.patch
+++ b/net-p2p/ed2k_hash/files/ed2k_64bit.patch
@@ -1,5 +1,5 @@
---- a/ed2k_hash/md4.h 2002-09-04 18:24:37.000000000 +0100
-+++ b/ed2k_hash/md4.h 2004-09-02 21:13:49.900613616 +0100
+--- a/ed2k_hash/md4.h
++++ b/ed2k_hash/md4.h
@@ -66,7 +66,8 @@
typedef unsigned short int UINT2;
diff --git a/net-p2p/ed2k_hash/files/ed2k_hash-0.4.0-missing-includes.patch b/net-p2p/ed2k_hash/files/ed2k_hash-0.4.0-missing-includes.patch
new file mode 100644
index 000000000000..4b9fcc109a38
--- /dev/null
+++ b/net-p2p/ed2k_hash/files/ed2k_hash-0.4.0-missing-includes.patch
@@ -0,0 +1,20 @@
+--- a/ed2k_hash/cl_ui.c
++++ b/ed2k_hash/cl_ui.c
+@@ -18,6 +18,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <stdarg.h>
++#include <string.h>
+
+ #include "global.h"
+
+--- a/ed2k_hash/options.c
++++ b/ed2k_hash/options.c
+@@ -16,6 +16,7 @@
+ ***************************************************************************/
+
+ #include <stdlib.h>
++#include <string.h>
+
+ #include "global.h"
+