summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2016-05-19 20:03:49 +1000
committerSam Jorna <wraeth@gentoo.org>2016-05-19 20:04:26 +1000
commit08a3e7653ec7b7dc612a55d15053ccb888f0e441 (patch)
treedfd4fafd0acae37465fe75a13a4e239784911217 /net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.1.ebuild
parentdev-libs/libfilezilla: Bump to version 0.5.1 (diff)
downloadgentoo-08a3e7653ec7b7dc612a55d15053ccb888f0e441.tar.gz
gentoo-08a3e7653ec7b7dc612a55d15053ccb888f0e441.tar.bz2
gentoo-08a3e7653ec7b7dc612a55d15053ccb888f0e441.zip
net-p2p/go-ipfs-bin: new package
IPFS is a decentralized torrent-like networking system with transparent file adding/downloading. Ebuild submitted by new proxied maintainer through bug. Gentoo-bug: 579768 Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.1.ebuild')
-rw-r--r--net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.1.ebuild b/net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.1.ebuild
new file mode 100644
index 000000000000..dc4a233b3465
--- /dev/null
+++ b/net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="go-ipfs is the main implementation of IPFS."
+HOMEPAGE="https://ipfs.io/"
+SRC_URI="https://dist.ipfs.io/go-ipfs/v${PV}/go-ipfs_v${PV}_linux-amd64.tar.gz
+ x86? ( https://dist.ipfs.io/go-ipfs/v${PV}/go-ipfs_v${PV}_linux-386.tar.gz )"
+# Also available arches:
+# arm? ( https://dist.ipfs.io/go-ipfs/v${PV}/go-ipfs_v${PV}_linux-arm.tar.gz )
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="+fuse"
+
+RDEPEND="fuse? ( sys-fs/fuse )"
+S="${WORKDIR}/go-ipfs"
+
+QA_PREBUILT="/usr/bin/ipfs"
+
+src_install() {
+ dobin ipfs
+}