summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2018-11-02 20:56:46 +0100
committerMichał Górny <mgorny@gentoo.org>2018-11-03 09:49:04 +0100
commit222255e0fdf1ad2ac3642a5bc488e689e0b84fc2 (patch)
treea3734b5ae4fe4266c4d43e967e0a48da842a42ed /net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.18.ebuild
parentdev-python/memory_profiler: Add blocker on dev-lang/mercury (diff)
downloadgentoo-222255e0fdf1ad2ac3642a5bc488e689e0b84fc2.tar.gz
gentoo-222255e0fdf1ad2ac3642a5bc488e689e0b84fc2.tar.bz2
gentoo-222255e0fdf1ad2ac3642a5bc488e689e0b84fc2.zip
net-p2p/go-ipfs-bin: verbump to 0.4.18
Signed-off-by: David Roman <davidroman96@gmail.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.18.ebuild')
-rw-r--r--net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.18.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.18.ebuild b/net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.18.ebuild
new file mode 100644
index 000000000000..f2e16b7beee3
--- /dev/null
+++ b/net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.18.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1 systemd user
+
+DESCRIPTION="Main implementation of IPFS"
+HOMEPAGE="https://ipfs.io/"
+SRC_URI="amd64? ( https://dist.ipfs.io/go-ipfs/v${PV}/go-ipfs_v${PV}_linux-amd64.tar.gz )
+ x86? ( https://dist.ipfs.io/go-ipfs/v${PV}/go-ipfs_v${PV}_linux-386.tar.gz )
+ arm? ( https://dist.ipfs.io/go-ipfs/v${PV}/go-ipfs_v${PV}_linux-arm.tar.gz )
+
+ https://raw.githubusercontent.com/ipfs/go-ipfs/v${PV}/misc/completion/ipfs-completion.bash -> ${P}.bash"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~x86"
+
+RDEPEND="sys-fs/fuse"
+S="${WORKDIR}/go-ipfs"
+
+QA_PREBUILT="/usr/bin/ipfs"
+
+src_install() {
+ dobin ipfs
+
+ systemd_dounit "${FILESDIR}/ipfs.service"
+ newinitd "${FILESDIR}/ipfs.init" ipfs
+ newconfd "${FILESDIR}/ipfs.confd" ipfs
+
+ newbashcomp "${DISTDIR}/${P}.bash" "ipfs"
+ keepdir /var/log/ipfs
+}
+
+pkg_preinst() {
+ enewgroup ipfs
+ enewuser ipfs "" "" /var/lib/ipfs ipfs
+
+ fowners -R ipfs:ipfs /var/log/ipfs
+}
+
+pkg_postinst() {
+ elog 'To be able to use the ipfs service you will need to create the ipfs repository'
+ elog '(eg: su -s /bin/sh -c "ipfs init -e" ipfs)'
+ elog 'or change IPFS_PATH of /etc/conf.d/ipfs with another with proper permissions.'
+}