summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-p2p/imule/imule-2.3.2.3-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-p2p/imule/imule-2.3.2.3-r1.ebuild')
-rw-r--r--net-p2p/imule/imule-2.3.2.3-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/net-p2p/imule/imule-2.3.2.3-r1.ebuild b/net-p2p/imule/imule-2.3.2.3-r1.ebuild
new file mode 100644
index 000000000000..83f41104860e
--- /dev/null
+++ b/net-p2p/imule/imule-2.3.2.3-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+WX_GTK_VER="2.8"
+inherit wxwidgets
+
+MY_PN="iMule"
+
+DESCRIPTION="P2P sharing software which connects through I2P and Kad networks"
+# New homepage has a few resources and a working nodes.dat file users need
+# in order to get iMule to work
+HOMEPAGE="http://echelon.i2p/imule"
+SRC_URI="http://dev.gentoo.org/~zlg/extra/net-p2p/imule/${MY_PN}-${PV}-src.tbz http://dev.gentoo.org/~zlg/extra/net-p2p/imule/2015-03-22_nodes.dat"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="webserver static-libs nls"
+RESTRICT="mirror"
+
+# wxGTK 2.8 is required; later versions result in failed compile
+# Other versions indicated are from the tarball's INSTALL file
+DEPEND="x11-libs/wxGTK:2.8
+ net-p2p/i2p
+ >=net-libs/libupnp-1.6.6
+ sys-devel/flex
+ sys-apps/texinfo
+ >=dev-libs/crypto++-5.1
+ !net-p2p/amule"
+RDEPEND="x11-libs/wxGTK:2.8 net-p2p/i2p"
+
+S="${WORKDIR}/${MY_PN}-${PV}-src"
+
+src_unpack() {
+ default
+ cp "${DISTDIR}"/2015-03-22_nodes.dat "${WORKDIR}"
+}
+
+src_configure() {
+ WX_GTK_VER="2.8" need-wxwidgets unicode
+ # Enabling imulecmd results in a compilation error.
+ econf --with-wx-config=${WX_CONFIG} \
+ --enable-imule-daemon \
+ --enable-alc \
+ --enable-alcc \
+ --enable-optimize \
+ --disable-debug \
+ $(use_enable nls) \
+ $(use_enable webserver) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ insinto /usr/share/${PN}
+ newins "${WORKDIR}"/2015-03-22_nodes.dat nodes.dat
+}
+
+pkg_postinst() {
+ elog "iMule will not function without a valid 'nodes.dat' file and"
+ elog "an I2P router running."
+ elog "A nodes.dat file can be found in /usr/share/imule. It can"
+ elog "be copied to ~/.iMule/nodes.dat for convenience."
+}