summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-08-03 16:14:14 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-08-03 16:14:53 +0200
commit9302c07d151576ce16e25ce1956c706f9dc07134 (patch)
tree4834a0ab1d0ea7981c79ee79949af1c99295c6d7 /net-p2p/ktorrent
parentdev-ros/ament_cppcheck: py improvments (diff)
downloadgentoo-9302c07d151576ce16e25ce1956c706f9dc07134.tar.gz
gentoo-9302c07d151576ce16e25ce1956c706f9dc07134.tar.bz2
gentoo-9302c07d151576ce16e25ce1956c706f9dc07134.zip
net-p2p/ktorrent: Fix tests
Upstream commit dfc063a4d1f174cd5f84b82154a58b86da334d35 Thanks-to: Frank Krömmelbein <kroemmelbein@gmx.de> Bug: https://bugs.gentoo.org/805065 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-p2p/ktorrent')
-rw-r--r--net-p2p/ktorrent/files/ktorrent-21.04.3-fix-tests.patch38
-rw-r--r--net-p2p/ktorrent/ktorrent-21.04.3.ebuild4
2 files changed, 41 insertions, 1 deletions
diff --git a/net-p2p/ktorrent/files/ktorrent-21.04.3-fix-tests.patch b/net-p2p/ktorrent/files/ktorrent-21.04.3-fix-tests.patch
new file mode 100644
index 000000000000..a6fe5f7be700
--- /dev/null
+++ b/net-p2p/ktorrent/files/ktorrent-21.04.3-fix-tests.patch
@@ -0,0 +1,38 @@
+From dfc063a4d1f174cd5f84b82154a58b86da334d35 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?=C3=96mer=20Fad=C4=B1l=20Usta?= <omerusta@gmail.com>
+Date: Tue, 18 May 2021 15:15:26 +0000
+Subject: [PATCH] Fix tests with new ecm sytle
+
+---
+ CMakeLists.txt | 2 ++
+ plugins/ipfilter/tests/CMakeLists.txt | 7 ++-----
+ 2 files changed, 4 insertions(+), 5 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e0f67a93..edc64983 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -17,6 +17,8 @@ set (KF5_MIN_VERSION "5.82")
+ set (LIBKTORRENT_MIN_VERSION "20.11.70")
+ set (Boost_MIN_VERSION "1.71.0")
+
++cmake_policy(SET CMP0115 OLD)
++
+ find_package(ECM ${KF5_MIN_VERSION} REQUIRED NO_MODULE)
+ set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${CMAKE_MODULE_PATH})
+
+diff --git a/plugins/ipfilter/tests/CMakeLists.txt b/plugins/ipfilter/tests/CMakeLists.txt
+index ec839aac..6c34b2d0 100644
+--- a/plugins/ipfilter/tests/CMakeLists.txt
++++ b/plugins/ipfilter/tests/CMakeLists.txt
+@@ -1,5 +1,2 @@
+-set(ipblocklisttest_SRCS ipblocklisttest.cpp ../ipblocklist.cpp)
+-add_executable(ipblocklisttest ${ipblocklisttest_SRCS})
+-add_test(ipblocklisttest ipblocklisttest)
+-ecm_mark_as_test(ipblocklisttest)
+-target_link_libraries(ipblocklisttest Qt5::Core Qt5::Network Qt5::Test ktcore)
++include(ECMAddTests)
++ecm_add_test(ipblocklisttest.cpp ../ipblocklist.cpp TEST_NAME ipblocklisttest LINK_LIBRARIES ktcore Qt5::Core Qt5::Network KF5::Torrent Qt5::Test)
+--
+GitLab
+
diff --git a/net-p2p/ktorrent/ktorrent-21.04.3.ebuild b/net-p2p/ktorrent/ktorrent-21.04.3.ebuild
index 2728b9034f1a..d43340869df7 100644
--- a/net-p2p/ktorrent/ktorrent-21.04.3.ebuild
+++ b/net-p2p/ktorrent/ktorrent-21.04.3.ebuild
@@ -21,7 +21,6 @@ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
IUSE="+bwscheduler +downloadorder +infowidget +ipfilter +kross +logviewer +magnetgenerator
+mediaplayer rss +scanfolder +shutdown +stats +upnp +webengine +zeroconf"
-BDEPEND="sys-devel/gettext"
COMMON_DEPEND="
>=dev-qt/qtdbus-${QTMIN}:5
>=dev-qt/qtgui-${QTMIN}:5
@@ -76,6 +75,9 @@ RDEPEND="${COMMON_DEPEND}
>=kde-frameworks/ktextwidgets-${KFMIN}:5
)
"
+BDEPEND="sys-devel/gettext"
+
+PATCHES=( "${FILESDIR}/${P}-fix-tests.patch" )
src_configure() {
local mycmakeargs=(