summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-31 04:57:38 +0100
committerSam James <sam@gentoo.org>2022-05-31 05:06:58 +0100
commitc45c35fd29bc2fbffd05ccb2a5f93f312ebe64ce (patch)
tree86c4306343e65f898184779a2451b1d1b6e576c7 /net-p2p/ncdc/ncdc-9999.ebuild
parentgui-libs/gtk: Drop old versions (diff)
downloadgentoo-c45c35fd29bc2fbffd05ccb2a5f93f312ebe64ce.tar.gz
gentoo-c45c35fd29bc2fbffd05ccb2a5f93f312ebe64ce.tar.bz2
gentoo-c45c35fd29bc2fbffd05ccb2a5f93f312ebe64ce.zip
net-p2p/ncdc: add 1.23
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-p2p/ncdc/ncdc-9999.ebuild')
-rw-r--r--net-p2p/ncdc/ncdc-9999.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/net-p2p/ncdc/ncdc-9999.ebuild b/net-p2p/ncdc/ncdc-9999.ebuild
index f6cebc9b3c0a..e001c6590371 100644
--- a/net-p2p/ncdc/ncdc-9999.ebuild
+++ b/net-p2p/ncdc/ncdc-9999.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="ncurses directconnect client"
HOMEPAGE="https://dev.yorhel.nl/ncdc"
-if [[ "${PV}" == *9999 ]] ; then
+if [[ ${PV} == *9999 ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="git://g.blicky.net/ncdc.git"
else
@@ -22,7 +22,7 @@ IUSE="geoip"
RDEPEND="
app-arch/bzip2
dev-db/sqlite:3
- dev-libs/glib:2
+ >=dev-libs/glib-2.32:2
net-libs/gnutls:=
sys-libs/ncurses:=[unicode(+)]
sys-libs/zlib:=
@@ -38,16 +38,19 @@ BDEPEND="
src_prepare() {
default
- [[ "${PV}" == *9999 ]] && eautoreconf
+
+ [[ ${PV} == *9999 ]] && eautoreconf
}
src_configure() {
local myeconfargs=(
$(use_with geoip)
)
- if [[ "${PV}" == *9999 ]] ; then
+
+ if [[ ${PV} == *9999 ]] ; then
myeconfargs+=( --enable-git-version )
fi
+
econf "${myeconfargs[@]}"
}