summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2021-12-19 21:39:43 +0100
committerPiotr Karbowski <slashbeast@gentoo.org>2021-12-19 21:42:44 +0100
commit2ceb632d678017aa810a02caa4fd6fc2aa89e95b (patch)
treef0da1537ca47c43b4b69742c911d24b01b21c535 /net-p2p/nicotine+
parentapp-admin/cronlocker: fix homepage (diff)
downloadgentoo-2ceb632d678017aa810a02caa4fd6fc2aa89e95b.tar.gz
gentoo-2ceb632d678017aa810a02caa4fd6fc2aa89e95b.tar.bz2
gentoo-2ceb632d678017aa810a02caa4fd6fc2aa89e95b.zip
net-p2p/nicotine+: 3.2.0 bump
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'net-p2p/nicotine+')
-rw-r--r--net-p2p/nicotine+/Manifest1
-rw-r--r--net-p2p/nicotine+/nicotine+-3.2.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/net-p2p/nicotine+/Manifest b/net-p2p/nicotine+/Manifest
index 9862ef8d2bc6..594c516a7f63 100644
--- a/net-p2p/nicotine+/Manifest
+++ b/net-p2p/nicotine+/Manifest
@@ -3,3 +3,4 @@ DIST nicotine+-3.0.2.tar.gz 3126152 BLAKE2B 8575c61fc32083e687eac841e403366c516e
DIST nicotine+-3.0.4.tar.gz 3141967 BLAKE2B d58072026ee766d81ca88dd4a11aa72f7aaee7a6e37c966e7d4cd0bdee40c8ef6537f01ea92c006b12e9692612d63fffd744011b982ee4cada2df03d2abae064 SHA512 8cc02b8b269267cc775b21ec246d84b932c1c7ef8f0983c63e3bb21de5b4c0de5fa65acdb0a07240b90c3529648f500d43fffbc0a462a260e534e86653a332a8
DIST nicotine+-3.0.6.tar.gz 2786594 BLAKE2B 69b43c3eec37c8a01a0bd42cd11c02580a5be9ca994106e34e7f588eaabb7cfa85fd312bd527d453e62b3f8c0fb4f031eedf06207e3c1d8602e822958d98ee65 SHA512 42846568948d45559206c85c7ed708be044a5cf55f994318c209506dcc9024d6ccfd141fa21ca57f00c320a1a5ec3ab09faf211ebd442bf1d5060b960f43e8c2
DIST nicotine+-3.1.1.tar.gz 2775643 BLAKE2B 9c595f8bf2bb4e7c79c3a5a57cadcfea8d2f0df6c89cd93f63f1e5c1117dbe5d85f98ac94c5f7e367e145869e136c701dbf61d1caa270959b29544ab5da17314 SHA512 28eaca5f270176ff5562f693906b4dfef180b91f0113332e3fc1659acaa6bb49e8f956b03612effab14f6833e9e7c00ebca75ca3c49906cd990d1e82e1bb5be3
+DIST nicotine+-3.2.0.tar.gz 3413614 BLAKE2B 8c63e5a1ee138dd4fbb27aaa160e381d40cf1bad95d86db454de4697ae5b0433309c33f9e6b6da1db2c862225159878fef483cd49f23d4cac14a98f17c43e4f9 SHA512 3c2299b9da44579060825a758cb45cd3a844bda405e99d411f714845c8dd662839d3158ac1ae3e197f4d1da68547ff161c3ed09dd35a95867e78faf0239b3b18
diff --git a/net-p2p/nicotine+/nicotine+-3.2.0.ebuild b/net-p2p/nicotine+/nicotine+-3.2.0.ebuild
new file mode 100644
index 000000000000..3717d1e247d6
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-3.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
+HOMEPAGE="https://github.com/Nicotine-Plus/nicotine-plus"
+SRC_URI="https://github.com/Nicotine-Plus/nicotine-plus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ ${DEPEND}
+"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/nicotine-plus-${PV}"
+
+src_install() {
+ distutils-r1_src_install
+ mv "${ED}/usr/share/doc/nicotine" "${ED}/usr/share/doc/${PF}" || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}