summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2022-10-19 21:46:46 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2022-10-19 21:46:46 +0200
commite4db2929c5491bff982a0c9dc2e8c424bdbc35fe (patch)
tree38a96664863dfbd33da83d8c17b28edc6bcb90f1 /net-p2p/nicotine+
parentnet-p2p/nicotine+: drop old. (diff)
downloadgentoo-e4db2929c5491bff982a0c9dc2e8c424bdbc35fe.tar.gz
gentoo-e4db2929c5491bff982a0c9dc2e8c424bdbc35fe.tar.bz2
gentoo-e4db2929c5491bff982a0c9dc2e8c424bdbc35fe.zip
net-p2p/nicotine+: 3.2.5 version bump.
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'net-p2p/nicotine+')
-rw-r--r--net-p2p/nicotine+/Manifest1
-rw-r--r--net-p2p/nicotine+/nicotine+-3.2.5.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/net-p2p/nicotine+/Manifest b/net-p2p/nicotine+/Manifest
index 1bf6394ed3b8..5674d536b2fa 100644
--- a/net-p2p/nicotine+/Manifest
+++ b/net-p2p/nicotine+/Manifest
@@ -1 +1,2 @@
DIST nicotine+-3.2.2.tar.gz 2868677 BLAKE2B d066f6ca54af627eb20a6bd76db57ece77ce00ca084d7f70efb7168a786a2666121126dc6e62ec9eddebf28ba370e5768a3e771f4ea34cf2073e782b8b74d8e0 SHA512 e8e28b7452a31b7221135e145eb7ee91e30a927a4dbf42bafa7d3380835f2cde4cbf28adc77041b80b6bc4d20d7a5e37043822933468e81dc9ca3458b152666d
+DIST nicotine+-3.2.5.tar.gz 2966816 BLAKE2B d42c8a7d253a7b58c414f67a0abd67c6ecd7523e0ec0b649275751a34c661a49b01ff67578cbd37af74c68696cd0afe9b0ee8a184172ad3f2b5a29d655d956cf SHA512 a71d096e7a77c0e147cb5b3d62d194967ae903fb6263b8fcb0819c67ab551fdb72be72326223d846e9584db97a22afc721b695205c26d79d579c6fe957d20644
diff --git a/net-p2p/nicotine+/nicotine+-3.2.5.ebuild b/net-p2p/nicotine+/nicotine+-3.2.5.ebuild
new file mode 100644
index 000000000000..66c30e2034be
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-3.2.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
+HOMEPAGE="https://github.com/Nicotine-Plus/nicotine-plus"
+SRC_URI="https://github.com/Nicotine-Plus/nicotine-plus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ ${DEPEND}
+"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/nicotine-plus-${PV}"
+
+EPYTEST_IGNORE=(
+ "test/integration/test_startup.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}