summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-12-22 22:28:30 +1100
committerMichael Palimaka <kensington@gentoo.org>2017-12-22 22:35:23 +1100
commitdb614eef02897a914aa2dd512f21d6ce5594ad5b (patch)
tree7df64113b87ba41f4a27e6e0d8805507eadfaecc /net-p2p/qbittorrent/qbittorrent-9999.ebuild
parentnet-misc/curl: clean up vulnerable versions, bug #638734 (diff)
downloadgentoo-db614eef02897a914aa2dd512f21d6ce5594ad5b.tar.gz
gentoo-db614eef02897a914aa2dd512f21d6ce5594ad5b.tar.bz2
gentoo-db614eef02897a914aa2dd512f21d6ce5594ad5b.zip
net-p2p/qbittorrent: sync live ebuild with latest release
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'net-p2p/qbittorrent/qbittorrent-9999.ebuild')
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index a946e1511962..24631e72b86e 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit cmake-utils
+inherit cmake-utils gnome2-utils xdg-utils
DESCRIPTION="BitTorrent client in C++ and Qt"
HOMEPAGE="https://www.qbittorrent.org/"
@@ -34,6 +34,7 @@ RDEPEND="
dbus? ( dev-qt/qtdbus:5 )
X? (
dev-qt/qtgui:5
+ dev-qt/qtsvg:5
dev-qt/qtwidgets:5
)"
DEPEND="${RDEPEND}
@@ -51,3 +52,13 @@ src_configure() {
)
cmake-utils_src_configure
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}