summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-10-04 15:12:10 -0400
committerMike Gilbert <floppym@gentoo.org>2022-10-04 15:12:10 -0400
commitd1131bf8afdd369ad559dd311af06522c260fd9f (patch)
treea92c11166cf09bd4af04d42fe074d77bb58507a2 /net-p2p/qbittorrent
parentsys-libs/libblockdev: add partial test dependencies (diff)
downloadgentoo-d1131bf8afdd369ad559dd311af06522c260fd9f.tar.gz
gentoo-d1131bf8afdd369ad559dd311af06522c260fd9f.tar.bz2
gentoo-d1131bf8afdd369ad559dd311af06522c260fd9f.zip
net-p2p/qbittorrent: rework multibuild logic
We want to control the GUI option with multibuild, not WEBUI. Bug: https://bugs.gentoo.org/839531 Bug: https://bugs.gentoo.org/864731 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.4.5-r1.ebuild (renamed from net-p2p/qbittorrent/qbittorrent-4.4.5.ebuild)22
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild22
2 files changed, 18 insertions, 26 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-4.4.5.ebuild b/net-p2p/qbittorrent/qbittorrent-4.4.5-r1.ebuild
index c84808b9cbcc..86809760e4f7 100644
--- a/net-p2p/qbittorrent/qbittorrent-4.4.5.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-4.4.5-r1.ebuild
@@ -46,8 +46,9 @@ BDEPEND="dev-qt/linguist-tools:5
DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
src_prepare() {
- MULTIBUILD_VARIANTS=( base )
- use webui && MULTIBUILD_VARIANTS+=( webui )
+ MULTIBUILD_VARIANTS=()
+ use gui && MULTIBUILD_VARIANTS+=( gui )
+ use webui && MULTIBUILD_VARIANTS+=( nogui )
cmake_src_prepare
}
@@ -70,20 +71,15 @@ src_configure() {
# Not yet in ::gentoo
-DQT6=OFF
- # We do these in multibuild, see bug #839531 for why.
- # Fedora has to do the same thing.
- -DGUI=$(usex gui)
+ -DWEBUI=$(usex webui)
)
- if [[ ${MULTIBUILD_VARIANT} == webui ]] ; then
- mycmakeargs+=(
- # Need to specify GUI here to allow webui settings
- # to appear in the GUI. bug #864731.
- -DGUI=$(usex gui)
- -DWEBUI=ON
- )
+ if [[ ${MULTIBUILD_VARIANT} == gui ]]; then
+ # We do this in multibuild, see bug #839531 for why.
+ # Fedora has to do the same thing.
+ mycmakeargs+=( -DGUI=ON )
else
- mycmakeargs+=( -DWEBUI=OFF )
+ mycmakeargs+=( -DGUI=OFF )
fi
cmake_src_configure
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index 467943b0deb1..dd26453408e2 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -47,8 +47,9 @@ BDEPEND="dev-qt/linguist-tools:5
DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md )
src_prepare() {
- MULTIBUILD_VARIANTS=( base )
- use webui && MULTIBUILD_VARIANTS+=( webui )
+ MULTIBUILD_VARIANTS=()
+ use gui && MULTIBUILD_VARIANTS+=( gui )
+ use webui && MULTIBUILD_VARIANTS+=( nogui )
cmake_src_prepare
}
@@ -71,22 +72,17 @@ src_configure() {
# Not yet in ::gentoo
-DQT6=OFF
- # We do these in multibuild, see bug #839531 for why.
- # Fedora has to do the same thing.
- -DGUI=$(usex gui)
+ -DWEBUI=$(usex webui)
-DTESTING=$(usex test)
)
- if [[ ${MULTIBUILD_VARIANT} == webui ]] ; then
- mycmakeargs+=(
- # Need to specify GUI here to allow webui settings
- # to appear in the GUI. bug #864731.
- -DGUI=$(usex gui)
- -DWEBUI=ON
- )
+ if [[ ${MULTIBUILD_VARIANT} == gui ]] ; then
+ # We do this in multibuild, see bug #839531 for why.
+ # Fedora has to do the same thing.
+ mycmakeargs+=( -DGUI=ON )
else
- mycmakeargs+=( -DWEBUI=OFF )
+ mycmakeargs+=( -DGUI=OFF )
fi
cmake_src_configure