summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2017-08-19 14:59:36 +0800
committerJason Zaman <perfinion@gentoo.org>2017-08-19 18:06:56 +0800
commitcd9ec0ed5640e05a515e3f68cad24e9dad23c3c7 (patch)
tree555c705b0fc5ee6c295e32d23a52b48b95c07ed3 /net-p2p/rtorrent/files/rtorrent-0.9.6-cppunit-pkgconfig.patch
parentdev-python/notebook: fix sandbox violation when USE=doc. (diff)
downloadgentoo-cd9ec0ed5640e05a515e3f68cad24e9dad23c3c7.tar.gz
gentoo-cd9ec0ed5640e05a515e3f68cad24e9dad23c3c7.tar.bz2
gentoo-cd9ec0ed5640e05a515e3f68cad24e9dad23c3c7.zip
net-p2p/rtorrent: fix building against cppunit (bug 620908)
Thanks to Nado and Ben Kohler Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'net-p2p/rtorrent/files/rtorrent-0.9.6-cppunit-pkgconfig.patch')
-rw-r--r--net-p2p/rtorrent/files/rtorrent-0.9.6-cppunit-pkgconfig.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-p2p/rtorrent/files/rtorrent-0.9.6-cppunit-pkgconfig.patch b/net-p2p/rtorrent/files/rtorrent-0.9.6-cppunit-pkgconfig.patch
new file mode 100644
index 000000000000..753f4cb8a7f3
--- /dev/null
+++ b/net-p2p/rtorrent/files/rtorrent-0.9.6-cppunit-pkgconfig.patch
@@ -0,0 +1,28 @@
+https://bugs.gentoo.org/620908
+
+diff -ur a/configure.ac b/configure.ac
+--- a/configure.ac 2017-08-17 08:52:49.596897308 -0500
++++ b/configure.ac 2017-08-17 08:54:57.171515415 -0500
+@@ -4,7 +4,6 @@
+
+ AM_INIT_AUTOMAKE
+ AC_CONFIG_HEADERS(config.h)
+-AM_PATH_CPPUNIT(1.9.6)
+
+ AC_PROG_CXX
+ AC_PROG_LIBTOOL
+@@ -43,9 +42,11 @@
+ fi])
+ ])
+
+-CFLAGS="$CFLAGS $PTHREAD_CFLAGS $CURSES_CFLAGS"
+-CXXFLAGS="$CXXFLAGS $PTHREAD_CFLAGS $CURSES_CFLAGS"
+-LIBS="$PTHREAD_LIBS $CURSES_LIB $CURSES_LIBS $LIBS"
++PKG_CHECK_MODULES([CPPUNIT], [cppunit],, [no_cppunit="yes"])
++
++CFLAGS="$CFLAGS $PTHREAD_CFLAGS $CPPUNIT_CFLAGS $CURSES_CFLAGS"
++CXXFLAGS="$CXXFLAGS $PTHREAD_CFLAGS $CPPUNIT_CFLAGS $CURSES_CFLAGS"
++LIBS="$PTHREAD_LIBS $CURSES_LIB $CURSES_LIBS $CPPUNIT_LIBS $LIBS"
+
+ PKG_CHECK_MODULES([libcurl], libcurl >= 7.15.4,
+ CXXFLAGS="$CXXFLAGS $libcurl_CFLAGS";