summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Shkardoon <ss23@ss23.geek.nz>2018-06-30 16:09:03 +1200
committerJason Zaman <perfinion@gentoo.org>2018-07-03 13:57:02 +0800
commit02114366f60e28c528b8f94c5a5f27ac25b5d3c9 (patch)
tree43ae5075f432521c01fc1971e1d99fd0de6d0f0c /net-p2p/rtorrent
parentdev-ruby/pdf-core: add ruby25 (diff)
downloadgentoo-02114366f60e28c528b8f94c5a5f27ac25b5d3c9.tar.gz
gentoo-02114366f60e28c528b8f94c5a5f27ac25b5d3c9.tar.bz2
gentoo-02114366f60e28c528b8f94c5a5f27ac25b5d3c9.zip
net-p2p/rtorrent: Patch configure to allow cross compiling
Patch already merged upstream https://github.com/rakshasa/rtorrent/pull/753 Closes: https://bugs.gentoo.org/show_bug.cgi?id=446186 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-p2p/rtorrent')
-rw-r--r--net-p2p/rtorrent/files/rtorrent-0.9.7-execinfo-configure.patch23
-rw-r--r--net-p2p/rtorrent/rtorrent-0.9.7-r1.ebuild74
2 files changed, 97 insertions, 0 deletions
diff --git a/net-p2p/rtorrent/files/rtorrent-0.9.7-execinfo-configure.patch b/net-p2p/rtorrent/files/rtorrent-0.9.7-execinfo-configure.patch
new file mode 100644
index 000000000000..2c7ce5222b80
--- /dev/null
+++ b/net-p2p/rtorrent/files/rtorrent-0.9.7-execinfo-configure.patch
@@ -0,0 +1,23 @@
+From f84670dd6394729158569a7a5366a00a7d1dccb2 Mon Sep 17 00:00:00 2001
+From: Stephen Shkardoon <ss23@ss23.geek.nz>
+Date: Mon, 25 Jun 2018 20:14:43 +1200
+Subject: [PATCH] Use AC_COMPILE instead of AC_RUN to check for execinfo.h
+
+This way enables cross compiling, since we don't need to run anything during the configure script.
+---
+ scripts/common.m4 | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/scripts/common.m4 b/scripts/common.m4
+index 9885b037..b1b815b1 100644
+--- a/scripts/common.m4
++++ b/scripts/common.m4
+@@ -153,7 +153,7 @@ dnl Need to fix this so that it uses the stuff defined by the system.
+ AC_DEFUN([TORRENT_CHECK_EXECINFO], [
+ AC_MSG_CHECKING(for execinfo.h)
+
+- AC_RUN_IFELSE([AC_LANG_SOURCE([
++ AC_COMPILE_IFELSE([AC_LANG_SOURCE([
+ #include <execinfo.h>
+ int main() { backtrace((void**)0, 0); backtrace_symbols((char**)0, 0); return 0;}
+ ])],
diff --git a/net-p2p/rtorrent/rtorrent-0.9.7-r1.ebuild b/net-p2p/rtorrent/rtorrent-0.9.7-r1.ebuild
new file mode 100644
index 000000000000..74bf66d2a2c7
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.9.7-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools linux-info systemd
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="https://rakshasa.github.io/rtorrent/"
+SRC_URI="http://rtorrent.net/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="daemon debug selinux test xmlrpc"
+
+COMMON_DEPEND="~net-libs/libtorrent-0.13.${PV##*.}
+ >=dev-libs/libsigc++-2.2.2:2
+ >=net-misc/curl-7.19.1
+ sys-libs/ncurses:0=
+ xmlrpc? ( dev-libs/xmlrpc-c )"
+RDEPEND="${COMMON_DEPEND}
+ daemon? ( app-misc/screen )
+ selinux? ( sec-policy/selinux-rtorrent )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/cppunit
+ virtual/pkgconfig"
+
+DOCS=( doc/rtorrent.rc )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.7-tinfo.patch"
+ "${FILESDIR}/${PN}-0.9.7-execinfo-configure.patch"
+)
+
+pkg_setup() {
+ if ! linux_config_exists || ! linux_chkconfig_present IPV6; then
+ ewarn "rtorrent will not start without IPv6 support in your kernel"
+ ewarn "without further configuration. Please set bind=0.0.0.0 or"
+ ewarn "similar in your rtorrent.rc"
+ ewarn "Upstream bug: https://github.com/rakshasa/rtorrent/issues/732"
+ fi
+}
+
+src_prepare() {
+ default
+
+ # https://github.com/rakshasa/rtorrent/issues/332
+ cp "${FILESDIR}"/rtorrent.1 "${S}"/doc/ || die
+
+ eautoreconf
+}
+
+src_configure() {
+ default
+
+ # configure needs bash or script bombs out on some null shift, bug #291229
+ CONFIG_SHELL=${BASH} econf \
+ --disable-dependency-tracking \
+ $(use_enable debug) \
+ $(use_with xmlrpc xmlrpc-c)
+}
+
+src_install() {
+ default
+ doman doc/rtorrent.1
+
+ if use daemon; then
+ newinitd "${FILESDIR}/rtorrentd.init" rtorrentd
+ newconfd "${FILESDIR}/rtorrentd.conf" rtorrentd
+ systemd_newunit "${FILESDIR}/rtorrentd_at.service" "rtorrentd@.service"
+ fi
+}