summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2022-11-05 03:15:20 +0100
committerLouis Sautier <sbraz@gentoo.org>2022-11-05 03:22:13 +0100
commitaa35d194bad0b5845fc9fdbe00b36de306c45708 (patch)
tree38c292103ebd6472af4f321603c66fa0995e5d3c /net-p2p/torrentinfo/torrentinfo-1.8.6-r3.ebuild
parentmedia-sound/jack-example-tools: Keyword 3 arm, #879669 (diff)
downloadgentoo-aa35d194bad0b5845fc9fdbe00b36de306c45708.tar.gz
gentoo-aa35d194bad0b5845fc9fdbe00b36de306c45708.tar.bz2
gentoo-aa35d194bad0b5845fc9fdbe00b36de306c45708.zip
net-p2p/torrentinfo: support Python 3.11, drop nose
Closes: https://bugs.gentoo.org/878719 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'net-p2p/torrentinfo/torrentinfo-1.8.6-r3.ebuild')
-rw-r--r--net-p2p/torrentinfo/torrentinfo-1.8.6-r3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-p2p/torrentinfo/torrentinfo-1.8.6-r3.ebuild b/net-p2p/torrentinfo/torrentinfo-1.8.6-r3.ebuild
new file mode 100644
index 000000000000..877569c19445
--- /dev/null
+++ b/net-p2p/torrentinfo/torrentinfo-1.8.6-r3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A torrent file parser"
+HOMEPAGE="https://github.com/Fuuzetsu/torrentinfo"
+SRC_URI="https://github.com/Fuuzetsu/torrentinfo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ # https://github.com/Fuuzetsu/torrentinfo/pull/16
+ "${FILESDIR}/${P}-fix-tests.patch"
+ # https://github.com/Fuuzetsu/torrentinfo/pull/18
+ "${FILESDIR}/${P}-remove-nose.patch"
+)
+
+distutils_enable_tests pytest