summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-07-21 00:39:17 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-07-21 00:50:49 +0200
commitc71cd289f0da5a7792cdffbfbff6619f0827f563 (patch)
tree8670313c429dd75344929deeaeffadcc95902562 /net-p2p/torrentinfo
parentnet-p2p/airdcpp-webclient: add Python 3.7 (diff)
downloadgentoo-c71cd289f0da5a7792cdffbfbff6619f0827f563.tar.gz
gentoo-c71cd289f0da5a7792cdffbfbff6619f0827f563.tar.bz2
gentoo-c71cd289f0da5a7792cdffbfbff6619f0827f563.zip
net-p2p/torrentinfo: EAPI=7, add Python 3.7
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'net-p2p/torrentinfo')
-rw-r--r--net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild b/net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild
new file mode 100644
index 000000000000..71e0fd696395
--- /dev/null
+++ b/net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A torrent file parser"
+HOMEPAGE="https://github.com/Fuuzetsu/torrentinfo"
+SRC_URI="https://github.com/Fuuzetsu/torrentinfo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+PATCHES=( "${FILESDIR}/${P}-fix-tests.patch" )
+
+python_test() {
+ nosetests test/tests.py || die "tests failed with ${EPYTHON}"
+}