summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-04-20 15:18:14 -0400
committerMike Gilbert <floppym@gentoo.org>2020-04-20 15:18:33 -0400
commitd21e2b71d496d3686cf17f8e0cc29bed0f8405b0 (patch)
tree4319aff367775ec0355f9c9165b704931e6c5d6a /net-p2p/transmission/transmission-9999.ebuild
parentx11-wm/mutter: x86 stable wrt bug #717144 (diff)
downloadgentoo-d21e2b71d496d3686cf17f8e0cc29bed0f8405b0.tar.gz
gentoo-d21e2b71d496d3686cf17f8e0cc29bed0f8405b0.tar.bz2
gentoo-d21e2b71d496d3686cf17f8e0cc29bed0f8405b0.zip
net-p2p/transmission: switch to cmake eclass
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'net-p2p/transmission/transmission-9999.ebuild')
-rw-r--r--net-p2p/transmission/transmission-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/net-p2p/transmission/transmission-9999.ebuild b/net-p2p/transmission/transmission-9999.ebuild
index b15f594478bb..f7f2735ac3c6 100644
--- a/net-p2p/transmission/transmission-9999.ebuild
+++ b/net-p2p/transmission/transmission-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 2006-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils systemd xdg-utils
+inherit cmake systemd xdg-utils
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -115,11 +115,11 @@ src_configure() {
-DWITH_SYSTEMD=$(usex systemd ON OFF)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
newinitd "${FILESDIR}"/transmission-daemon.initd.10 transmission-daemon
newconfd "${FILESDIR}"/transmission-daemon.confd.4 transmission-daemon