summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-25 22:50:02 +0000
committerSam James <sam@gentoo.org>2022-03-25 23:12:34 +0000
commit11d0272c9bdb7cc66868309466069420a0619935 (patch)
treef7b63ed7e731c8ed5696be727089502a1b0597ba /net-p2p
parentgames-puzzle/gnome-sudoku: Version bump to 42.0 (diff)
downloadgentoo-11d0272c9bdb7cc66868309466069420a0619935.tar.gz
gentoo-11d0272c9bdb7cc66868309466069420a0619935.tar.bz2
gentoo-11d0272c9bdb7cc66868309466069420a0619935.zip
net-p2p/qbittorrent: add 4.4.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.4.2.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index 95eee3d5e26c..23e4adc6e437 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -2,3 +2,4 @@ DIST qbittorrent-4.3.8.tar.gz 8506355 BLAKE2B e59be1556ad0be697e32d69d890115df6c
DIST qbittorrent-4.3.9.tar.gz 8510414 BLAKE2B de98aff6d81f43c3ad87f6c5f800a4488e18173fb96713d0a2420cf4d4708c9b1f2f54c8d0aa566e7738b4f94d192aad9f0196a05d43724582ef81833901727f SHA512 ec33f67895fbf47acc2f79d9c9e16db8b96c756cf493b76eb24b90e13a790a709104ea9aa378ee111d8c38b605bed5192b366d1917bbf160b21aa2ae3aacd2d1
DIST qbittorrent-4.4.0.tar.gz 9037875 BLAKE2B b3789151a0e8b75bebecd84edcb5d75a1cf82674a5984c0ac8bb85d73dc90285fc7109b11ba593cd721fc4a45e87a69e00e85a47d79ed87423e538f56f2334c8 SHA512 7b1d4d45884d90bec14a28f01c9bdab0c9e2af496ade219393f4ccb14b9bb2901fc043407186da0efa1176f7fc9d1b1478864588e3869e363eb0eb35e5fe5c3f
DIST qbittorrent-4.4.1.tar.gz 9090594 BLAKE2B 1b0d4900352c069177913a2ef66bd986a45d13d52f191b824a4dbd38d84b037a7410a9c71cf487d537a5ce70b00e8f695c20acd85ede963731a84f39c9b8ee5c SHA512 155e0394e1599fbbae4b03fc39a13085eb4f797fdf7ff45d2c552c66cdb523e146b77da4fa0f14d6b5b64e3b56f9da7163fd544811a40a9a787848007bfbd0a6
+DIST qbittorrent-4.4.2.tar.gz 9197188 BLAKE2B 719ca031b1a5523cd29582d7d57ac48e5d3cfb8b1c62e23f01d116897e7753cda204a0dc401f364860eba750371f41178d87ae6d1f43241506868d90a8bc9e32 SHA512 55656fb5fd282a3ed0e703b9b47ec9733a70cf6242cae956a5b2487ef2aeb88a04bf5d37c8fa88554edf95ab0821b76ebebb53e8fc43dc5889f8c730075d6e26
diff --git a/net-p2p/qbittorrent/qbittorrent-4.4.2.ebuild b/net-p2p/qbittorrent/qbittorrent-4.4.2.ebuild
new file mode 100644
index 000000000000..85869e0799fd
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-4.4.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake systemd xdg
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org
+ https://github.com/qbittorrent"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+else
+ SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ S="${WORKDIR}/qBittorrent-release-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus +gui webui"
+REQUIRED_USE="dbus? ( gui )"
+
+RDEPEND="
+ >=dev-libs/boost-1.65.0-r1:=
+ dev-libs/openssl:=
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5
+ dev-qt/qtxml:5
+ >=net-libs/libtorrent-rasterbar-1.2.14:=
+ sys-libs/zlib
+ dbus? ( dev-qt/qtdbus:5 )
+ gui? (
+ dev-libs/geoip
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+
+src_configure() {
+ local mycmakeargs=(
+ -DDBUS=$(usex dbus)
+ -DGUI=$(usex gui)
+ -DWEBUI=$(usex webui)
+
+ # musl lacks execinfo.h
+ -DSTACKTRACE=$(usex !elibc_musl)
+
+ # We always want to install unit files
+ -DSYSTEMD=ON
+ -DSYSTEMD_SERVICES_INSTALL_DIR=$(systemd_get_systemunitdir)
+
+ # More verbose build logs are preferable for bug reports
+ -DVERBOSE_CONFIGURE=ON
+
+ # Not yet in ::gentoo
+ -DQT6=OFF
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ einstalldocs
+}