summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus P Rey (Chuso) <gentoo@chuso.net>2020-07-11 13:59:23 +0200
committerSam James <sam@gentoo.org>2020-10-17 02:24:29 +0000
commit1b70b64f68dfe5c09a67f106131448b4fc3f7643 (patch)
tree1f8842bc07bc71bf17ce0fe74f2c28a1aea8c077 /net-p2p
parentacct-user/p2p: new package (378) (diff)
downloadgentoo-1b70b64f68dfe5c09a67f106131448b4fc3f7643.tar.gz
gentoo-1b70b64f68dfe5c09a67f106131448b4fc3f7643.tar.bz2
gentoo-1b70b64f68dfe5c09a67f106131448b4fc3f7643.zip
net-p2p/mldonkey: version bump to 3.1.7
Signed-off-by: Jesus P Rey <gentoo@chuso.net> Bug: https://bugs.gentoo.org/595798 Bug: https://bugs.gentoo.org/705582 Closes: https://bugs.gentoo.org/582136 Closes: https://bugs.gentoo.org/615322 Closes: https://bugs.gentoo.org/635932 Closes: https://bugs.gentoo.org/704684 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/mldonkey/Manifest1
-rw-r--r--net-p2p/mldonkey/mldonkey-3.1.7.ebuild183
2 files changed, 184 insertions, 0 deletions
diff --git a/net-p2p/mldonkey/Manifest b/net-p2p/mldonkey/Manifest
index 153e81fe19b3..8513fd906db5 100644
--- a/net-p2p/mldonkey/Manifest
+++ b/net-p2p/mldonkey/Manifest
@@ -1,2 +1,3 @@
DIST mldonkey-3.1.5.tar.bz2 2847382 BLAKE2B 60df6ffba295d0a230f1ca2d143e21529387fb453529cd89e84911b72248c0fec15261b7d3ed54be2c8d1de84bf4e8faaebcfa2019960af845493fb2385e46c8 SHA512 96e75acf91d7ecc41490f898e06d284da27404c7e567f173936d8113885a3b4b6bc93341358f92a30d3f699eef681d97ce56414a37bb02a535ad2da4d4ad13a3
DIST mldonkey-3.1.6.tar.bz2 2886916 BLAKE2B f92c7195c67e3a9186cb9e691114dc2c1b967dab93a7c280a6fe25c2f3a18d97e849f738d0f4669f0e967c3b717ed0329f40d95c07be13a46fb5a96fc49ff716 SHA512 d0c7256c7c43934bc132183cfe0c8d85c61a874e295b86ba989f43fd4d9f3672bdf18439a9fefce52c30a6a8df08a5a464dcc21d4bf199d1b502fa344683081a
+DIST mldonkey-3.1.7-2.tar.bz2 2801815 BLAKE2B f914648b4e2a358e51518f3b58dc0df803cdb28d7706783504644266690514c17c2cae0688011073391db221eb8f38c7cbaf1e913220d824e41ca2e23d4c8587 SHA512 11cb0fa0db95e918c291009f4121a1b34cf485e5ac6826a72a4dc520dd78d21ced40d205fa26eb451c7d3eb31f2193cbb64e46c99c85dc932762c1bcc4da4934
diff --git a/net-p2p/mldonkey/mldonkey-3.1.7.ebuild b/net-p2p/mldonkey/mldonkey-3.1.7.ebuild
new file mode 100644
index 000000000000..5bfcb0e2e21e
--- /dev/null
+++ b/net-p2p/mldonkey/mldonkey-3.1.7.ebuild
@@ -0,0 +1,183 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools desktop flag-o-matic toolchain-funcs
+
+DESCRIPTION="Multi-network P2P application written in Ocaml, with Gtk, web & telnet interface"
+HOMEPAGE="http://mldonkey.sourceforge.net/ https://github.com/ygrek/mldonkey"
+SRC_URI="https://github.com/ygrek/mldonkey/releases/download/release-${PV//./-}-2/${P}-2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="bittorrent doc fasttrack gd gnutella gtk guionly magic +ocamlopt upnp"
+
+REQUIRED_USE="guionly? ( gtk )"
+
+RDEPEND="dev-lang/perl
+ dev-ml/camlp4:=
+ gd? ( media-libs/gd[truetype] )
+ gtk? (
+ gnome-base/librsvg
+ dev-ml/lablgtk[svg]
+ )
+ guionly? (
+ gnome-base/librsvg
+ dev-ml/lablgtk
+ )
+ magic? ( sys-apps/file )
+ upnp? (
+ net-libs/libnatpmp
+ net-libs/miniupnpc:=
+ )
+ !guionly? ( acct-user/p2p )
+"
+
+DEPEND="${RDEPEND}
+ <dev-lang/ocaml-4.10[ocamlopt?]
+ bittorrent? (
+ || (
+ <dev-lang/ocaml-4.06
+ (
+ >=dev-lang/ocaml-4.06
+ dev-ml/num
+ )
+ )
+ )"
+
+RESTRICT="!ocamlopt? ( strip )"
+
+S="${WORKDIR}/${P}-2"
+
+pkg_setup() {
+ if use gtk; then
+ echo ""
+ einfo "If the compile with gui fails, and you have updated Ocaml"
+ einfo "recently, you may have forgotten that you need to run"
+ einfo "/usr/portage/dev-lang/ocaml/files/ocaml-rebuild.sh"
+ einfo "to learn which ebuilds you need to recompile"
+ einfo "each time you update Ocaml to a different version"
+ einfo "see the Ocaml ebuild for details"
+ echo ""
+ fi
+
+ # dev-lang/ocaml creates its own objects but calls gcc for linking, which will
+ # results in relocations if gcc wants to create a PIE executable
+ if gcc-specs-pie ; then
+ append-ldflags -nopie
+ ewarn "Ocaml generates its own native asm, you're using a PIE compiler"
+ ewarn "We have appended -nopie to ocaml build options"
+ ewarn "because linking an executable with pie while the objects are not pic will not work"
+ fi
+}
+
+src_prepare() {
+ cd config || die
+ eautoconf
+ cd .. || die
+ if ! use ocamlopt; then
+ sed -i -e "s/ocamlopt/idontwantocamlopt/g" "${S}/config/configure" || die "failed to disable ocamlopt"
+ fi
+
+ default
+}
+
+src_configure() {
+ local myconf=()
+
+ if use gtk; then
+ myconf+=( --enable-gui=newgui2 )
+ else
+ myconf+=( --disable-gui )
+ fi
+
+ if use guionly; then
+ myconf+=( --disable-multinet --disable-donkey )
+ fi
+
+ local my_extra_libs
+ if use gd; then
+ my_extra_libs="-lpng"
+ fi
+
+ econf LIBS="${my_extra_libs}"\
+ --sysconfdir=/etc/mldonkey \
+ --sharedstatedir=/var/mldonkey \
+ --localstatedir=/var/mldonkey \
+ --enable-checks \
+ --disable-batch \
+ $(use_enable bittorrent) \
+ $(use_enable fasttrack) \
+ $(use_enable gnutella) \
+ $(use_enable gnutella gnutella2) \
+ $(use_enable gd) \
+ $(use_enable magic) \
+ $(use_enable upnp upnp-natpmp) \
+ --disable-force-upnp-natpmp \
+ ${myconf[@]}
+}
+
+src_compile() {
+ export OCAMLRUNPARAM="l=256M"
+ emake -j1 # Upstream bug #48
+
+ if ! use guionly; then
+ emake utils
+ fi
+}
+
+src_install() {
+ local myext i
+ use ocamlopt || myext=".byte"
+ if ! use guionly; then
+ for i in mlnet mld_hash get_range copysources subconv; do
+ newbin "${i}${myext}" "${i}"
+ done
+ use bittorrent && newbin "make_torrent${myext}" make_torrent
+
+ newconfd "${FILESDIR}/mldonkey.confd-2.8" mldonkey
+ fperms 600 /etc/conf.d/mldonkey
+ newinitd "${FILESDIR}/mldonkey.initd" mldonkey
+ fi
+
+ if use gtk; then
+ for i in mlgui mlguistarter; do
+ newbin "${i}${myext}" "${i}"
+ done
+ make_desktop_entry mlgui "MLDonkey GUI" mldonkey "Network;P2P"
+ newicon "${S}"/packages/rpm/mldonkey-icon-48.png "${PN}.png"
+ fi
+
+ if use doc ; then
+ docompress -x "/usr/share/doc/${PF}/scripts" "/usr/share/doc/${PF}/html"
+
+ dodoc distrib/ChangeLog distrib/*.txt docs/*.txt docs/*.tex docs/*.pdf docs/developers/*.{txt,tex}
+
+ docinto scripts
+ dodoc distrib/{kill_mldonkey,mldonkey_command,mldonkey_previewer,make_buginfo}
+
+ docinto html
+ dodoc docs/*.html
+
+ docinto html/images
+ dodoc docs/images/*
+ fi
+}
+
+pkg_postinst() {
+ if ! use guionly; then
+ echo
+ einfo "If you want to start MLDonkey as a system service, use"
+ einfo "the /etc/init.d/mldonkey script. To control bandwidth, use"
+ einfo "the 'slow' and 'fast' arguments. Be sure to have a look at"
+ einfo "/etc/conf.d/mldonkey also."
+ echo
+ else
+ echo
+ einfo "Simply run mlgui to start the chosen MLDonkey gui."
+ einfo "It puts its config files into ~/.mldonkey"
+ fi
+}