summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2020-02-03 10:56:57 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-02-20 15:17:20 +0200
commit2912503476a06505e0575648bdc85e1238ed17fd (patch)
treef460659862de9037d91845dfb78c03a13790066c /net-p2p
parentmedia-radio/gpredict: Fix build with -fno-common (diff)
downloadgentoo-2912503476a06505e0575648bdc85e1238ed17fd.tar.gz
gentoo-2912503476a06505e0575648bdc85e1238ed17fd.tar.bz2
gentoo-2912503476a06505e0575648bdc85e1238ed17fd.zip
net-p2p/amule: fix build with binutils-2.34
Closes: https://bugs.gentoo.org/707884 Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/amule/amule-2.3.2-r4.ebuild1
-rw-r--r--net-p2p/amule/files/amule-2.3.2-Fixed-compilation-with-newer-bfd.patch33
2 files changed, 34 insertions, 0 deletions
diff --git a/net-p2p/amule/amule-2.3.2-r4.ebuild b/net-p2p/amule/amule-2.3.2-r4.ebuild
index 8199a8471f05..eee88909130a 100644
--- a/net-p2p/amule/amule-2.3.2-r4.ebuild
+++ b/net-p2p/amule/amule-2.3.2-r4.ebuild
@@ -45,6 +45,7 @@ PATCHES=(
"${FILESDIR}/${PN}-2.3.2-fix-crash-when-shared-files-changed.patch"
"${FILESDIR}/${PN}-2.3.2-libupnp-1.8.patch"
"${FILESDIR}/${PN}-2.3.2-libupnp-1.6.patch"
+ "${FILESDIR}/${PN}-2.3.2-Fixed-compilation-with-newer-bfd.patch"
)
pkg_setup() {
diff --git a/net-p2p/amule/files/amule-2.3.2-Fixed-compilation-with-newer-bfd.patch b/net-p2p/amule/files/amule-2.3.2-Fixed-compilation-with-newer-bfd.patch
new file mode 100644
index 000000000000..3ef8a21fa45c
--- /dev/null
+++ b/net-p2p/amule/files/amule-2.3.2-Fixed-compilation-with-newer-bfd.patch
@@ -0,0 +1,33 @@
+From c0c28234a40b1b575ce51cdfe5ffa5dac3a7494c Mon Sep 17 00:00:00 2001
+From: Werner Mahr <werner@vollstreckernet.de>
+Date: Fri, 31 Jan 2020 17:55:24 +0100
+Subject: [PATCH] Fixed compilation with newer bfd. Fixes: #174
+
+---
+ src/libs/common/MuleDebug.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/libs/common/MuleDebug.cpp b/src/libs/common/MuleDebug.cpp
+index 5d8d75890..0ebf2ab07 100644
+--- a/src/libs/common/MuleDebug.cpp
++++ b/src/libs/common/MuleDebug.cpp
+@@ -268,14 +268,14 @@ void get_file_line_info(bfd *abfd, asection *section, void* _address)
+ return;
+ }
+
+- bfd_vma vma = bfd_get_section_vma(abfd, section);
++ bfd_vma vma = section->vma;
+
+ unsigned long address = (unsigned long)_address;
+ if (address < vma) {
+ return;
+ }
+
+- bfd_size_type size = bfd_section_size(abfd, section);
++ bfd_size_type size = section->size;
+ if (address > (vma + size)) {
+ return;
+ }
+--
+2.24.1
+