summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-16 11:36:07 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-16 11:39:37 +0200
commit2ba34f12ffa132f756c19c43880f1a7b226f0be0 (patch)
tree1050f3b59e6e8521cab69d18b0f45bdb5576f56b /net-p2p
parentapp-shells/tcsh: add patch to fix USE=-nls, bug #689904 (diff)
downloadgentoo-2ba34f12ffa132f756c19c43880f1a7b226f0be0.tar.gz
gentoo-2ba34f12ffa132f756c19c43880f1a7b226f0be0.tar.bz2
gentoo-2ba34f12ffa132f756c19c43880f1a7b226f0be0.zip
net-p2p/qbittorrent: EAPI-7, drop gnome2-utils, fix bug w/ Qt-5.12.4
Upstream commit 9a4dd3ea9d1fc2af0cc5724ebb19fc99297c2960 Reported-by: Nikos Chantziaras <realnc@gmail.com> Bug: https://bugs.gentoo.org/689704 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/files/qbittorrent-4.1.6-no-screenblank-on-close-to-systray.patch25
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.1.6-r1.ebuild72
2 files changed, 97 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/files/qbittorrent-4.1.6-no-screenblank-on-close-to-systray.patch b/net-p2p/qbittorrent/files/qbittorrent-4.1.6-no-screenblank-on-close-to-systray.patch
new file mode 100644
index 000000000000..361f7aa22553
--- /dev/null
+++ b/net-p2p/qbittorrent/files/qbittorrent-4.1.6-no-screenblank-on-close-to-systray.patch
@@ -0,0 +1,25 @@
+From 9a4dd3ea9d1fc2af0cc5724ebb19fc99297c2960 Mon Sep 17 00:00:00 2001
+From: Ekin Dursun <ekindursun@gmail.com>
+Date: Tue, 7 May 2019 02:08:46 +0300
+Subject: [PATCH] Don't turn screen blank when closed to system tray
+
+Closes #9240 and possibly #9121, as @zeule suggested here: https://github.com/qbittorrent/qBittorrent/issues/9240#issuecomment-408025722.
+---
+ src/gui/mainwindow.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/gui/mainwindow.cpp b/src/gui/mainwindow.cpp
+index 4c62ba5d90..0b8b41ebab 100644
+--- a/src/gui/mainwindow.cpp
++++ b/src/gui/mainwindow.cpp
+@@ -1158,8 +1158,8 @@ void MainWindow::closeEvent(QCloseEvent *e)
+ #else
+ const bool goToSystrayOnExit = pref->closeToTray();
+ if (!m_forceExit && m_systrayIcon && goToSystrayOnExit && !this->isHidden()) {
+- hide();
+- e->accept();
++ e->ignore();
++ QTimer::singleShot(0, this, &QWidget::hide);
+ if (!pref->closeToTrayNotified()) {
+ showNotificationBaloon(tr("qBittorrent is closed to tray"), tr("This behavior can be changed in the settings. You won't be reminded again."));
+ pref->setCloseToTrayNotified(true);
diff --git a/net-p2p/qbittorrent/qbittorrent-4.1.6-r1.ebuild b/net-p2p/qbittorrent/qbittorrent-4.1.6-r1.ebuild
new file mode 100644
index 000000000000..ae75d7415fa6
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-4.1.6-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org
+ https://github.com/qbittorrent"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+else
+ SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+ S="${WORKDIR}/qBittorrent-release-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus debug webui +X"
+REQUIRED_USE="dbus? ( X )"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+RDEPEND="
+ >=dev-libs/boost-1.62.0-r1:=
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt5(+),X?]
+ dev-qt/qtxml:5
+ =net-libs/libtorrent-rasterbar-1.1*:0=
+ sys-libs/zlib
+ dbus? ( dev-qt/qtdbus:5 )
+ X? (
+ dev-libs/geoip
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-no-screenblank-on-close-to-systray.patch" )
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+
+src_configure() {
+ econf --with-qtsingleapplication=system \
+ $(use_enable dbus qt-dbus) \
+ $(use_enable debug) \
+ $(use_enable webui) \
+ $(use_enable X gui)
+}
+
+src_install() {
+ emake STRIP="/bin/false" INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}