summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2023-02-18 23:39:46 -0600
committerJohn Helmert III <ajak@gentoo.org>2023-02-19 10:44:59 -0600
commit3a424d93466be0d2fc71b4d3632d8a741b531e77 (patch)
treedd0acc943a76a2853353d883f1b881c8ef4f372c /net-p2p
parentnet-p2p/arti: add 1.1.1 (diff)
downloadgentoo-3a424d93466be0d2fc71b4d3632d8a741b531e77.tar.gz
gentoo-3a424d93466be0d2fc71b4d3632d8a741b531e77.tar.bz2
gentoo-3a424d93466be0d2fc71b4d3632d8a741b531e77.zip
net-p2p/arti: sync live
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/arti/arti-9999.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/net-p2p/arti/arti-9999.ebuild b/net-p2p/arti/arti-9999.ebuild
index 8a8e33f3433e..a4531b132f02 100644
--- a/net-p2p/arti/arti-9999.ebuild
+++ b/net-p2p/arti/arti-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -16,7 +16,7 @@ if [[ "${PV}" == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.torproject.org/tpo/core/arti"
else
- SRC_URI="https://gitlab.torproject.org/tpo/core/${PN}/-/archive/${PN}-v${PV}/${PN}-${PN}-v${PV}.tar.gz -> ${P}.tar.gz
+ SRC_URI="https://gitlab.torproject.org/tpo/core/${PN}/-/archive/${PN}-v${PV}/${PN}-${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2
$(cargo_crate_uris ${CRATES})"
KEYWORDS="~amd64"
S="${WORKDIR}/${MY_P}"
@@ -42,8 +42,11 @@ src_unpack() {
}
src_compile() {
- pushd crates/arti || die
- cargo_src_compile
+ for crate in crates/*; do
+ pushd crates/arti || die
+ cargo_src_compile
+ popd >/dev/null || die
+ done
}
src_test() {