summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-12-17 23:05:02 +0100
committerGöktürk Yüksek <gokturk@gentoo.org>2016-12-18 14:11:00 -0500
commit44e64c0634df7f125cbabd1d4ad5b932545c18e5 (patch)
tree95b11626cbf58883212df0d090b0e738c35dab06 /net-p2p
parentnet-misc/openvswitch: fix ovs-vswitchd.service (diff)
downloadgentoo-44e64c0634df7f125cbabd1d4ad5b932545c18e5.tar.gz
gentoo-44e64c0634df7f125cbabd1d4ad5b932545c18e5.tar.bz2
gentoo-44e64c0634df7f125cbabd1d4ad5b932545c18e5.zip
net-p2p/syncthing: bump to 0.14.15
Package-Manager: portage-2.3.3
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/syncthing/Manifest1
-rw-r--r--net-p2p/syncthing/syncthing-0.14.15.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/net-p2p/syncthing/Manifest b/net-p2p/syncthing/Manifest
index 1c9a1772b819..213f401a071b 100644
--- a/net-p2p/syncthing/Manifest
+++ b/net-p2p/syncthing/Manifest
@@ -1 +1,2 @@
DIST syncthing-0.14.14.tar.gz 5947169 SHA256 a719570ebe206a1ad97044db73d92298131d3858d5af8a22e579627592c52a4e SHA512 0b5934d87aa04b23e1059249c2dc3e4f1214825826e9c2b201487af33c991187e7b9909f41b29ee424cf4ec9d93be42f584af995eaee06d35297e0bfd8e316b4 WHIRLPOOL fa3c9aa13f5baea2600042763733469a7bdacb82c971c98f9fe0e430129fc3922fe118f356b312db33f35fbb12e18589b917ed7377ec90a14c3d2fd92e2eb84b
+DIST syncthing-0.14.15.tar.gz 5947702 SHA256 3e28e80ada8efc0c7ee5ddffc950befcea7d87aa2b456ce60df8e681baa80cc9 SHA512 489d78d1cbf4ec56515ced721904ebafad7d7f6b2e62936d98fc1f30ed1457295a6b6882822fb4a0481c3bbc60e824dd5785730cbcfa76afdd6b53401bdff1ac WHIRLPOOL 16ed5cb58308de777c455e96b3bade0d9f54e0b47c75441b0db67c2b03772756d7c1391c87fd5efe79296f2e119baabfc75dd2ecd59718db6aba081b42d032ca
diff --git a/net-p2p/syncthing/syncthing-0.14.15.ebuild b/net-p2p/syncthing/syncthing-0.14.15.ebuild
new file mode 100644
index 000000000000..ca243eeb355a
--- /dev/null
+++ b/net-p2p/syncthing/syncthing-0.14.15.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGO_PN="github.com/${PN}/${PN}"
+
+inherit golang-vcs-snapshot systemd user versionator
+
+DESCRIPTION="Open Source Continuous File Synchronization"
+HOMEPAGE="https://syncthing.net"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~arm"
+IUSE="tools"
+
+DOCS=(README.md AUTHORS CONTRIBUTING.md)
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+
+ if use tools ; then
+ # separate user for the relay server
+ enewgroup strelaysrv
+ enewuser strelaysrv -1 -1 /var/lib/strelaysrv strelaysrv
+ # and his home folder
+ keepdir /var/lib/strelaysrv
+ fowners strelaysrv:strelaysrv /var/lib/strelaysrv
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i \
+ 's|^ExecStart=.*|ExecStart=/usr/libexec/syncthing/strelaysrv|' \
+ src/${EGO_PN}/cmd/strelaysrv/etc/linux-systemd/strelaysrv.service \
+ || die
+}
+
+src_compile() {
+ export GOPATH="${S}:$(get_golibdir_gopath)"
+ cd src/${EGO_PN} || die
+ go run build.go -version "v${PV}" -no-upgrade install \
+ $(usex tools "all" "") || die "build failed"
+}
+
+src_test() {
+ cd src/${EGO_PN} || die
+ go run build.go test || die "test failed"
+}
+
+src_install() {
+ pushd src/${EGO_PN} >& /dev/null || die
+ doman man/*.[157]
+ einstalldocs
+
+ dobin bin/syncthing
+ if use tools ; then
+ exeinto /usr/libexec/syncthing
+ local exe
+ for exe in bin/* ; do
+ [[ "${exe}" == "bin/syncthing" ]] || doexe "${exe}"
+ done
+ fi
+ popd >& /dev/null || die
+
+ # openrc and systemd service files
+ systemd_dounit src/${EGO_PN}/etc/linux-systemd/system/${PN}{@,-resume}.service
+ systemd_douserunit src/${EGO_PN}/etc/linux-systemd/user/${PN}.service
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+
+ keepdir /var/{lib,log}/${PN}
+ fowners ${PN}:${PN} /var/{lib,log}/${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotate" ${PN}
+
+ if use tools ; then
+ # openrc and systemd service files
+ systemd_dounit src/${EGO_PN}/cmd/strelaysrv/etc/linux-systemd/strelaysrv.service
+ newconfd "${FILESDIR}/strelaysrv.confd" strelaysrv
+ newinitd "${FILESDIR}/strelaysrv.initd" strelaysrv
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/strelaysrv.logrotate" strelaysrv
+ fi
+}
+
+pkg_postinst() {
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if [[ $(get_version_component_range 2) -gt \
+ $(get_version_component_range 2 ${v}) ]]; then
+ ewarn "Version ${PV} is not protocol-compatible with version" \
+ "0.$(($(get_version_component_range 2) - 1)).x or lower."
+ ewarn "Make sure all your devices are running at least version" \
+ "0.$(get_version_component_range 2).0."
+ fi
+ done
+
+ # check if user syncthing-relaysrv exists
+ # if yes, warn that it has been moved to strelaysrv
+ if [[ -n "$(egetent passwd syncthing-relaysrv 2>/dev/null)" ]]; then
+ ewarn
+ ewarn "The user and group for the relay server have been changed"
+ ewarn "from syncthing-relaysrv to strelaysrv"
+ ewarn "The old user and group are not deleted automatically. Delete them by running:"
+ ewarn " userdel -r syncthing-relaysrv"
+ ewarn " groupdel syncthing-relaysrv"
+ fi
+}