summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-06-14 11:39:16 -0400
committerCraig Andrews <candrews@gentoo.org>2023-06-14 11:39:36 -0400
commit5568e7779a4ae6eb107a2134453aea1abd43ff9f (patch)
treedd1fea3bb0a909599484eb4994ade1027d060fd8 /net-p2p
parentdev-libs/ntl: Stabilize 11.5.1-r4 x86, #908494 (diff)
downloadgentoo-5568e7779a4ae6eb107a2134453aea1abd43ff9f.tar.gz
gentoo-5568e7779a4ae6eb107a2134453aea1abd43ff9f.tar.bz2
gentoo-5568e7779a4ae6eb107a2134453aea1abd43ff9f.zip
net-p2p/cpuminer-opt: add 3.22.3
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.22.3.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 0bdc7703a4af..57fedf5ad9ea 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1 +1,2 @@
DIST cpuminer-opt-3.22.1.tar.gz 1788067 BLAKE2B 38fd425cdfed4378c66be41ee5021bfaab47adc9c8c53f1b99b05efb30dd891bc8ca7feceb7eb8e5998cf0c8536eb582370f9955a0117917f18e451dbd90e1a6 SHA512 39157cd22a9923dec15e040e5aa11b28d8197fd4b906384989354d6f9f13073671264de5b8c251283ad137d778c70b36be5a3f7bc4f11555579892ee0f61cc41
+DIST cpuminer-opt-3.22.3.tar.gz 1784148 BLAKE2B 1a2fa789bcbb29c43df540d729a76f3f0d68fa2577302df3081eb2e951aad84b51f4defefa825ae8c32480a77c28a803dd1b9fc3ab4ff3141b4e479aeb107075 SHA512 230d3b3528266675bc6b1d304e36940306c389f4678ba6b092fd12d4ac3d98dfc10c334a9565319f4e39212f0a5d2f73220271ce093582f48eaa444098591de3
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.22.3.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.22.3.ebuild
new file mode 100644
index 000000000000..dd862b295bd0
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.22.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:=
+ dev-libs/jansson:=
+ >=net-misc/curl-7.15[ssl]
+ dev-libs/openssl:0=
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}