summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-01-23 08:52:22 -0500
committerCraig Andrews <candrews@gentoo.org>2020-01-23 08:52:40 -0500
commit580376a82d18df168479230aad2ed987cfc05263 (patch)
treed912a6091d3b0627f814f7cab1711808e1541bcc /net-p2p
parentmedia-libs/libprojectm: Cleanup old versions (diff)
downloadgentoo-580376a82d18df168479230aad2ed987cfc05263.tar.gz
gentoo-580376a82d18df168479230aad2ed987cfc05263.tar.bz2
gentoo-580376a82d18df168479230aad2ed987cfc05263.zip
net-p2p/cpuminer-opt: 3.11.6 version bump
Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.11.6.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 21280aa99e16..b0bb7498c585 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1 +1,2 @@
DIST cpuminer-opt-3.11.5.tar.gz 1927342 BLAKE2B 92f5bc74e6ef31ff320e502807d884dd0106ae3c28722b0b453b7a9c1d9568596e9beab1ee9d2a5a5ab1f1ad184f04d4cf012503393407a8133d3c806764fafa SHA512 7b31286a4d8a3613ace70be85cd80f7645d148a19b1707ea9c4b0c0b023b656a7bac37587e21a9db5477074e04ce1b87fdac794be999c284c51b0b7680be12e8
+DIST cpuminer-opt-3.11.6.tar.gz 1927145 BLAKE2B 8cb90a3a419011b98c5105e80aafcf0918934f9648fc2719d876430e6d706e7010a78c01c2b281f7c371a06be9df514dad0bad0c6b8eff456fe14ba9d74ac3f0 SHA512 bfe2df3ba577195781f92b4d96c34a5ea991217b59a5de4f1931458a8475ff630bd9779965110484b2540def1aea5c84de6136203a82c664e968c195a0e494ee
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.11.6.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.11.6.ebuild
new file mode 100644
index 000000000000..a5d436b3b8b8
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.11.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ >=net-misc/curl-7.15[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}