summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2021-03-11 21:32:07 +0100
committerPiotr Karbowski <slashbeast@gentoo.org>2021-03-11 21:34:23 +0100
commit5ace3d5a5d46438fa400e3f190eb91bf40ddeb1c (patch)
tree8bce0e9015a619b0ff7bab0803f42bbde9c6f179 /net-p2p
parentsys-fs/mergerfs: 2.32.4 version bump. (diff)
downloadgentoo-5ace3d5a5d46438fa400e3f190eb91bf40ddeb1c.tar.gz
gentoo-5ace3d5a5d46438fa400e3f190eb91bf40ddeb1c.tar.bz2
gentoo-5ace3d5a5d46438fa400e3f190eb91bf40ddeb1c.zip
net-p2p/nicotine+: 3.0.2 version bump.
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/nicotine+/Manifest1
-rw-r--r--net-p2p/nicotine+/nicotine+-3.0.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/net-p2p/nicotine+/Manifest b/net-p2p/nicotine+/Manifest
index d5b14a0cf699..bf64814e94fa 100644
--- a/net-p2p/nicotine+/Manifest
+++ b/net-p2p/nicotine+/Manifest
@@ -2,3 +2,4 @@ DIST nicotine+-2.0.1.tar.gz 5140065 BLAKE2B 01af7eb58ea6800c17042ef73b9caa8b3d57
DIST nicotine+-2.1.2.tar.gz 5091941 BLAKE2B 2fcfcc25645a194e1161502c1836d075732a833e1cca1f16cb939e960371c9a656c0044427ca381e8fb3d76de139af1f495b3c5ff208fe931571cfbe5ab0d219 SHA512 dc5ae656cb24efdd252475eefa63d471e44f9652650ca834acb358c195337c46c07ef5da873419d66235a8fbb3d2e290347aa47416c0017bea54423b485225c9
DIST nicotine+-2.2.0.tar.gz 3382047 BLAKE2B 64e83aee32f16ff8fcd298a4f876eca1903a37879918bdf3d1e4684d17b1815caf991ffc0264273fb3b84ab77a300382050039b3c5977a38d1e94ba060f7b58e SHA512 1a3aa24fe09564dbd2cd454e081eb5198279a968a4ab8df0b7f42ea1da63b24ac28ea4000fabf4cf00c6b37d4395b927321d27c1502de3447001285d0c942439
DIST nicotine+-2.2.2.tar.gz 3373462 BLAKE2B 6dbcf4e9d7f85bb2e03194047c8ca9c374ae762967414d888e764e84b25682148245cf84c27ab967279f4ac5e3bad680a7920d3da7896e61d12413194c9ad207 SHA512 5d863b94d1a899701f3d6cd98d875a4ca782778b00d77fe3c490af59168592011a83f823feac6c0e71bdd4c5cfd743e023066d542d8778b68854344b73c322a1
+DIST nicotine+-3.0.2.tar.gz 3126152 BLAKE2B 8575c61fc32083e687eac841e403366c516e0420c792bad2bf31b49b83dd80d2b99ace20879f7968dffd0d48e52bc6c6638300216b4eae44773c0723888ca96e SHA512 297aab9b6016df4b45e065d5e6493e237e99ef6ebbd475b7ccf66d2c476053f77c72c2ecd672c20046b422dc1f5eb431e701de687d33f2364619de5643ccef6d
diff --git a/net-p2p/nicotine+/nicotine+-3.0.2.ebuild b/net-p2p/nicotine+/nicotine+-3.0.2.ebuild
new file mode 100644
index 000000000000..7ed3e7ea3cba
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-3.0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
+HOMEPAGE="https://github.com/Nicotine-Plus/nicotine-plus"
+SRC_URI="https://github.com/Nicotine-Plus/nicotine-plus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ ${DEPEND}
+"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/nicotine-plus-${PV}"
+
+src_install() {
+ distutils-r1_src_install
+ mv "${ED}/usr/share/doc/nicotine" "${ED}/usr/share/doc/${PF}" || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}