summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-05-06 15:05:53 -0400
committerCraig Andrews <candrews@gentoo.org>2021-05-06 15:25:48 -0400
commit7363030d7a48616a6cfcc64bb0443ffd8991a8c2 (patch)
tree2570adb2b67e076618e625c7e9250733683270ad /net-p2p
parentdev-python/dash-html-components: fix BadFilename (diff)
downloadgentoo-7363030d7a48616a6cfcc64bb0443ffd8991a8c2.tar.gz
gentoo-7363030d7a48616a6cfcc64bb0443ffd8991a8c2.tar.bz2
gentoo-7363030d7a48616a6cfcc64bb0443ffd8991a8c2.zip
net-p2p/cpuminer-opt: 3.16.3 version bump
Closes: https://bugs.gentoo.org/787230 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.16.3.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 6470c20168bf..cf2e66daf564 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1 +1,2 @@
DIST cpuminer-opt-3.16.2.tar.gz 1829567 BLAKE2B 01f0383f1e6f46bb71c548df5f69e808e7ccaa3aa7217530464b86bc629843f632405f9ca57f9201cd337e774ebe8ca6fa2fe8b8ec0e0042bb0844d8bd9f6c0c SHA512 bc0d9970afee6f6d5cdfbe7517c7d201fccb9ef133dc51494b03bfa1b4e0e8e40927cffee8ff811b077f6d39b2bc61e96bba1c162f68470fd702e1b3383a6357
+DIST cpuminer-opt-3.16.3.tar.gz 1829694 BLAKE2B 2cf8f7f03a60956d7c84e55fd4bbee27025488bfcda2b6f02d7defe4983cc78fcf827591d1ed7998e859ffe67ce4baeb6ab53abc2f5c7552e5c3b19e66740501 SHA512 28d361c7889073b4b67981676183e114d9ccdda3529e2f8703948169d6edf91b9fe9cbe152edafbefa3d7b285dadf415cdea130df48af86323453c66a07d6513
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.16.3.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.16.3.ebuild
new file mode 100644
index 000000000000..fb5ffe94cd29
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.16.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ >=net-misc/curl-7.15[ssl]
+ dev-libs/openssl:0=
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}