summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-03-27 08:36:26 +0200
committerHans de Graaff <graaff@gentoo.org>2022-03-27 09:13:12 +0200
commit75691c2bdf441c9981d09122f7bff01abcc3d269 (patch)
tree95318e8cdf5efce942e15041d2c503a203a1db2b /net-p2p
parentdev-ruby/net-ftp: initial import of 0.1.3 (diff)
downloadgentoo-75691c2bdf441c9981d09122f7bff01abcc3d269.tar.gz
gentoo-75691c2bdf441c9981d09122f7bff01abcc3d269.tar.bz2
gentoo-75691c2bdf441c9981d09122f7bff01abcc3d269.zip
net-p2p/gtk-gnutella: drop 1.2.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/gtk-gnutella/gtk-gnutella-1.2.1.ebuild89
1 files changed, 0 insertions, 89 deletions
diff --git a/net-p2p/gtk-gnutella/gtk-gnutella-1.2.1.ebuild b/net-p2p/gtk-gnutella/gtk-gnutella-1.2.1.ebuild
deleted file mode 100644
index c81ce2d3af4e..000000000000
--- a/net-p2p/gtk-gnutella/gtk-gnutella-1.2.1.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic strip-linguas toolchain-funcs
-
-IUSE="nls dbus ssl +gtk"
-
-DESCRIPTION="A GTK+ Gnutella client"
-SRC_URI="https://github.com/gtk-gnutella/gtk-gnutella/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-HOMEPAGE="http://gtk-gnutella.sourceforge.net/"
-
-SLOT="0"
-LICENSE="CC-BY-SA-4.0 GPL-2"
-KEYWORDS="amd64 ppc ppc64 x86"
-
-RDEPEND="
- sys-libs/binutils-libs:=
- dev-libs/glib:2
- sys-libs/zlib
- gtk? ( >=x11-libs/gtk+-2.2.1:2 )
- dbus? ( >=sys-apps/dbus-0.35.2 )
- ssl? ( >=net-libs/gnutls-2.2.5 )
- nls? ( >=sys-devel/gettext-0.11.5 )"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-src_prepare() {
- filter-flags -flto
- strip-linguas -i po
-
- echo "# Gentoo-selected LINGUAS" > po/LINGUAS
- for ling in ${LINGUAS}; do
- echo $ling >> po/LINGUAS
- done
-
- default
-}
-
-src_configure() {
- # There is no option to turn off optimization through the build.sh
- # script.
- sed -i -e "s/Configure -Oder/Configure -Oder -Doptimize=none/" build.sh || die
-
- # The build script does not support the equivalent --enable
- # options so we must construct the configuration by hand.
-
- local myconf
-
- if ! use nls; then
- myconf="${myconf} --disable-nls"
- fi
-
- if ! use dbus; then
- myconf="${myconf} --disable-dbus"
- fi
-
- if ! use ssl; then
- myconf="${myconf} --disable-gnutls"
- fi
-
- if use gtk; then
- myconf="${myconf} --gtk2"
- else
- myconf="${myconf} --topless"
- fi
-
- ./build.sh \
- --configure-only \
- --prefix="/usr" \
- --cc="$(tc-getCC)" \
- ${myconf}
-}
-
-src_compile() {
- # Build system is not parallel-safe, bug 500760
- emake -j1
-}
-
-src_install() {
- dodir /usr/bin
- emake INSTALL_PREFIX="${D}" install
- dodoc AUTHORS ChangeLog README TODO
-
- # Touch the symbols file into the future to avoid warnings from
- # gtk-gnutella later on, since we will most likely strip the binary.
- touch --date="next minute" "${D}/usr/lib/gtk-gnutella/gtk-gnutella.nm" || die
-}