summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-12-06 03:27:31 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-12-06 15:30:30 +0100
commit78a93544e314828fd32ea5d9afb7b8d6851617f7 (patch)
tree7ad83692198a8590a26e56b486b7bb94c58215f0 /net-p2p
parentapp-office/gnucash: HTTP -> HTTPS Homepage (diff)
downloadgentoo-78a93544e314828fd32ea5d9afb7b8d6851617f7.tar.gz
gentoo-78a93544e314828fd32ea5d9afb7b8d6851617f7.tar.bz2
gentoo-78a93544e314828fd32ea5d9afb7b8d6851617f7.zip
net-p2p/airdcpp-webclient: bump to 2.10.0
Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/airdcpp-webclient/Manifest1
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-2.10.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index 939b97599d4c..5c88cb3bfcbc 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1,2 +1,3 @@
+DIST airdcpp-webclient-2.10.0.tar.gz 963410 BLAKE2B 9cbc04d023d9478d48b177cfb457cdaff11a8079388078125ccecf5936cbac8e22aea3cddae9dd21b76b6d24d586ae4799bf2a8e67929d1134a2218a57aa9c3b SHA512 c80ec28198550846feda6d3dfd01ea0e0b402cab6753c1f7976df4bda0d8a8a2124d1ae7a437dbb15446665ec199decf897e49edd6aaf7f3983e7b7e7dc645e5
DIST airdcpp-webclient-2.8.1.tar.gz 945274 BLAKE2B e98ea603d52f041fed1a60a2c6dd4bff141c230bd554ccc6e7f013a28bd2ef8f2001e5343d3233d09b7cc9ef7e1af8b45a18757f59d29cdfb592763375c01e0c SHA512 c75b20591deb62a62dfb26df1536c521073643d3d7893d2ac85f2206c52a1786349a980994084abf840d1610000128247e6ae94aecf31b1d5266224086257ca7
DIST airdcpp-webclient-2.9.0.tar.gz 967670 BLAKE2B f10c4a44e724f178f55f79ca2a0711f29933a11112e18106bc12833d45971bb51867b00c6ef2a74f4c4eafaedbb7da47d7dcc97959d03794aeeb626ee727df4c SHA512 c0b6dc30aa5b2dbb40096b530c5cb7d5c46dc085b04e6277384d98ce9120988bd471a95995267def42323dafe0b99f760aba07f181d2211b27db20b31adad142
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-2.10.0.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.10.0.ebuild
new file mode 100644
index 000000000000..1f5aa45d38d6
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.10.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+
+inherit cmake python-any-r1 systemd
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://airdcpp-web.github.io/"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="debug nat-pmp +tbb +webui"
+
+RDEPEND="
+ acct-user/airdcppd
+ acct-group/airdcppd
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost:=
+ dev-libs/leveldb:=
+ dev-libs/libmaxminddb:=
+ dev-libs/openssl:0=[-bindist]
+ net-libs/miniupnpc:=
+ sys-libs/zlib
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp:= )
+ tbb? ( dev-cpp/tbb:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_NATPMP=$(usex nat-pmp)
+ -DENABLE_TBB=$(usex tbb)
+ -DINSTALL_WEB_UI=OFF
+ )
+ CMAKE_BUILD_TYPE=$(usex debug Debug Gentoo) cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ systemd_dounit "${FILESDIR}/airdcppd.service"
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}