summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-04-17 20:45:26 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-04-17 21:19:33 +0200
commit7e696b56897a2e6f4cf587463aa682de025fe8f2 (patch)
tree7b32ce5103d3061639f7ac6c2cf4e6250761796d /net-p2p
parentnet-misc/sstp-client: drop old version (diff)
downloadgentoo-7e696b56897a2e6f4cf587463aa682de025fe8f2.tar.gz
gentoo-7e696b56897a2e6f4cf587463aa682de025fe8f2.tar.bz2
gentoo-7e696b56897a2e6f4cf587463aa682de025fe8f2.zip
net-p2p/litecoind: migrate to glep 81
Closes: https://bugs.gentoo.org/781449 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/litecoind/litecoind-0.10.4.0-r1.ebuild108
1 files changed, 108 insertions, 0 deletions
diff --git a/net-p2p/litecoind/litecoind-0.10.4.0-r1.ebuild b/net-p2p/litecoind/litecoind-0.10.4.0-r1.ebuild
new file mode 100644
index 000000000000..47158fa5e560
--- /dev/null
+++ b/net-p2p/litecoind/litecoind-0.10.4.0-r1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DB_VER="4.8"
+
+inherit autotools db-use flag-o-matic systemd
+
+MY_PV="${PV/_/-}"
+MY_PN="litecoin"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="The offical daemon to run your own (full) Litecoin node"
+HOMEPAGE="https://litecoin.org/"
+SRC_URI="https://github.com/${MY_PN}-project/${MY_PN}/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT ISC GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="logrotate upnp +wallet"
+
+RDEPEND="
+ acct-group/litecoin
+ acct-user/litecoin
+ dev-libs/boost:=[threads(+)]
+ dev-libs/leveldb:=
+ dev-libs/openssl:0[-bindist]
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+ logrotate? ( app-admin/logrotate )
+ upnp? ( net-libs/miniupnpc )
+"
+DEPEND="
+ ${RDEPEND}
+ >=app-shells/bash-4.1
+ sys-apps/sed
+"
+
+PATCHES=(
+ "${FILESDIR}"/0.9.0-sys_leveldb.patch
+ "${FILESDIR}"/litecoind-0.10.2.2-memenv_h.patch
+ "${FILESDIR}"/litecoind-0.10.2.2-fix-gnustack.patch
+ "${FILESDIR}"/${P}-gcc6.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+ rm -r src/leveldb
+}
+
+src_configure() {
+ # To avoid executable GNU stack.
+ append-ldflags -Wl,-z,noexecstack
+
+ local my_econf=
+ if use upnp; then
+ my_econf="${my_econf} --with-miniupnpc --enable-upnp-default"
+ else
+ my_econf="${my_econf} --without-miniupnpc --disable-upnp-default"
+ fi
+
+ local myeconfargs=(
+ $(use_enable wallet)
+ --disable-ccache
+ --disable-static
+ --disable-tests
+ --with-system-leveldb
+ --with-system-libsecp256k1
+ --without-libs
+ --with-daemon
+ --without-gui
+ --without-qrencode
+ ${my_econf}
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ insinto /etc/litecoin
+ doins "${FILESDIR}/litecoin.conf"
+ fowners litecoin:litecoin /etc/litecoin/litecoin.conf
+ fperms 600 /etc/litecoin/litecoin.conf
+
+ newconfd "${FILESDIR}/litecoin.confd" ${PN}
+ newinitd "${FILESDIR}/litecoin.initd-r1" ${PN}
+ systemd_dounit "${FILESDIR}/litecoin.service"
+
+ keepdir /var/lib/litecoin/.litecoin
+ fperms 700 /var/lib/litecoin
+ fowners litecoin:litecoin /var/lib/litecoin/
+ fowners litecoin:litecoin /var/lib/litecoin/.litecoin
+ dosym /etc/litecoin/litecoin.conf /var/lib/litecoin/.litecoin/litecoin.conf
+
+ dodoc doc/README.md doc/release-notes.md
+ newman contrib/debian/manpages/bitcoind.1 litecoind.1
+ newman contrib/debian/manpages/bitcoin.conf.5 litecoin.conf.5
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/litecoind.logrotate" litecoind
+ fi
+}