summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-08 07:55:43 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:46:44 +0100
commit7f5848e0a74dcdf5125e2c752d602d495fcdcbd9 (patch)
treeebd777d007b8dae8c51f007b576b357b9752cc7a /net-p2p
parentnet-misc/streamlink: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-7f5848e0a74dcdf5125e2c752d602d495fcdcbd9.tar.gz
gentoo-7f5848e0a74dcdf5125e2c752d602d495fcdcbd9.tar.bz2
gentoo-7f5848e0a74dcdf5125e2c752d602d495fcdcbd9.zip
net-p2p/deluge: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/deluge/deluge-1.3.15-r5.ebuild (renamed from net-p2p/deluge/deluge-1.3.15-r2.ebuild)46
-rw-r--r--net-p2p/deluge/deluge-1.3.15-r6.ebuild (renamed from net-p2p/deluge/deluge-1.3.15-r3.ebuild)49
-rw-r--r--net-p2p/deluge/deluge-1.3.15-r7.ebuild (renamed from net-p2p/deluge/deluge-1.3.15-r4.ebuild)49
-rw-r--r--net-p2p/deluge/deluge-1.3.9999.ebuild49
-rw-r--r--net-p2p/deluge/deluge-2.0.3-r4.ebuild (renamed from net-p2p/deluge/deluge-2.0.3-r2.ebuild)49
-rw-r--r--net-p2p/deluge/deluge-2.0.3-r5.ebuild (renamed from net-p2p/deluge/deluge-2.0.3-r3.ebuild)49
-rw-r--r--net-p2p/deluge/deluge-9999.ebuild49
7 files changed, 187 insertions, 153 deletions
diff --git a/net-p2p/deluge/deluge-1.3.15-r2.ebuild b/net-p2p/deluge/deluge-1.3.15-r5.ebuild
index f49c58d5c41a..61514eb8e1d1 100644
--- a/net-p2p/deluge/deluge-1.3.15-r2.ebuild
+++ b/net-p2p/deluge/deluge-1.3.15-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -34,30 +34,34 @@ PATCHES=(
"${FILESDIR}/${PN}-1.3.15-r1-fix-preferences-ui.patch"
)
-CDEPEND="net-libs/libtorrent-rasterbar[python,${PYTHON_USEDEP}]"
+CDEPEND="
+ $(python_gen_cond_dep '
+ net-libs/libtorrent-rasterbar[python,${PYTHON_MULTI_USEDEP}]
+ ')"
DEPEND="${CDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
dev-util/intltool"
RDEPEND="${CDEPEND}
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pyxdg[${PYTHON_USEDEP}]
- dev-python/setproctitle[${PYTHON_USEDEP}]
- || ( >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
- (
- >=dev-python/twisted-core-13.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-web-13.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyxdg[${PYTHON_MULTI_USEDEP}]
+ dev-python/setproctitle[${PYTHON_MULTI_USEDEP}]
+ || ( >=dev-python/twisted-16.0.0[${PYTHON_MULTI_USEDEP}]
+ (
+ >=dev-python/twisted-core-13.0[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/twisted-web-13.0[${PYTHON_MULTI_USEDEP}]
+ )
)
- )
- geoip? ( dev-python/geoip-python[${PYTHON_USEDEP}] )
- gtk? (
- sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
- dev-python/pygobject:2[${PYTHON_USEDEP}]
- >=dev-python/pygtk-2.12[${PYTHON_USEDEP}]
- gnome-base/librsvg
- libnotify? ( dev-python/notify-python[${PYTHON_USEDEP}] )
- )
- webinterface? ( dev-python/mako[${PYTHON_USEDEP}] )"
+ geoip? ( dev-python/geoip-python[${PYTHON_MULTI_USEDEP}] )
+ gtk? (
+ sound? ( dev-python/pygame[${PYTHON_MULTI_USEDEP}] )
+ dev-python/pygobject:2[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pygtk-2.12[${PYTHON_MULTI_USEDEP}]
+ gnome-base/librsvg
+ libnotify? ( dev-python/notify-python[${PYTHON_MULTI_USEDEP}] )
+ )
+ webinterface? ( dev-python/mako[${PYTHON_MULTI_USEDEP}] )
+ ')"
python_prepare_all() {
local args=(
diff --git a/net-p2p/deluge/deluge-1.3.15-r3.ebuild b/net-p2p/deluge/deluge-1.3.15-r6.ebuild
index d3ef7813a7a0..f044210962ad 100644
--- a/net-p2p/deluge/deluge-1.3.15-r3.ebuild
+++ b/net-p2p/deluge/deluge-1.3.15-r6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -33,29 +33,34 @@ PATCHES=(
"${FILESDIR}/${PN}-1.3.15-r1-fix-preferences-ui.patch"
)
-DEPEND="<net-libs/libtorrent-rasterbar-1.2[python,${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
+ $(python_gen_cond_dep '
+ <net-libs/libtorrent-rasterbar-1.2[python,${PYTHON_MULTI_USEDEP}]
+ ')
dev-util/intltool"
-RDEPEND="<net-libs/libtorrent-rasterbar-1.2[python,${PYTHON_USEDEP}]
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pyxdg[${PYTHON_USEDEP}]
- dev-python/setproctitle[${PYTHON_USEDEP}]
- || ( >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
- (
- >=dev-python/twisted-core-13.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-web-13.0[${PYTHON_USEDEP}]
+RDEPEND="
+ $(python_gen_cond_dep '
+ <net-libs/libtorrent-rasterbar-1.2[python,${PYTHON_MULTI_USEDEP}]
+ dev-python/chardet[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyxdg[${PYTHON_MULTI_USEDEP}]
+ dev-python/setproctitle[${PYTHON_MULTI_USEDEP}]
+ || ( >=dev-python/twisted-16.0.0[${PYTHON_MULTI_USEDEP}]
+ (
+ >=dev-python/twisted-core-13.0[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/twisted-web-13.0[${PYTHON_MULTI_USEDEP}]
+ )
)
- )
- geoip? ( dev-python/geoip-python[${PYTHON_USEDEP}] )
- gtk? (
- sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
- dev-python/pygobject:2[${PYTHON_USEDEP}]
- >=dev-python/pygtk-2.12[${PYTHON_USEDEP}]
- gnome-base/librsvg
- libnotify? ( dev-python/notify-python[${PYTHON_USEDEP}] )
- )
- webinterface? ( dev-python/mako[${PYTHON_USEDEP}] )"
+ geoip? ( dev-python/geoip-python[${PYTHON_MULTI_USEDEP}] )
+ gtk? (
+ sound? ( dev-python/pygame[${PYTHON_MULTI_USEDEP}] )
+ dev-python/pygobject:2[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pygtk-2.12[${PYTHON_MULTI_USEDEP}]
+ gnome-base/librsvg
+ libnotify? ( dev-python/notify-python[${PYTHON_MULTI_USEDEP}] )
+ )
+ webinterface? ( dev-python/mako[${PYTHON_MULTI_USEDEP}] )
+ ')"
python_prepare_all() {
local args=(
diff --git a/net-p2p/deluge/deluge-1.3.15-r4.ebuild b/net-p2p/deluge/deluge-1.3.15-r7.ebuild
index d938267bcd80..13817ba74ca2 100644
--- a/net-p2p/deluge/deluge-1.3.15-r4.ebuild
+++ b/net-p2p/deluge/deluge-1.3.15-r7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -32,31 +32,36 @@ PATCHES=(
"${FILESDIR}/${PN}-1.3.15-r1-fix-preferences-ui.patch"
)
-DEPEND="<net-libs/libtorrent-rasterbar-1.2[python,${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
+ $(python_gen_cond_dep '
+ <net-libs/libtorrent-rasterbar-1.2[python,${PYTHON_MULTI_USEDEP}]
+ ')
dev-util/intltool
acct-group/deluge
acct-user/deluge"
-RDEPEND="<net-libs/libtorrent-rasterbar-1.2[python,${PYTHON_USEDEP}]
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pyxdg[${PYTHON_USEDEP}]
- dev-python/setproctitle[${PYTHON_USEDEP}]
- || ( >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
- (
- >=dev-python/twisted-core-13.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-web-13.0[${PYTHON_USEDEP}]
+RDEPEND="
+ $(python_gen_cond_dep '
+ <net-libs/libtorrent-rasterbar-1.2[python,${PYTHON_MULTI_USEDEP}]
+ dev-python/chardet[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyxdg[${PYTHON_MULTI_USEDEP}]
+ dev-python/setproctitle[${PYTHON_MULTI_USEDEP}]
+ || ( >=dev-python/twisted-16.0.0[${PYTHON_MULTI_USEDEP}]
+ (
+ >=dev-python/twisted-core-13.0[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/twisted-web-13.0[${PYTHON_MULTI_USEDEP}]
+ )
)
- )
- geoip? ( dev-python/geoip-python[${PYTHON_USEDEP}] )
- gtk? (
- sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
- dev-python/pygobject:2[${PYTHON_USEDEP}]
- >=dev-python/pygtk-2.12[${PYTHON_USEDEP}]
- gnome-base/librsvg
- libnotify? ( dev-python/notify-python[${PYTHON_USEDEP}] )
- )
- webinterface? ( dev-python/mako[${PYTHON_USEDEP}] )"
+ geoip? ( dev-python/geoip-python[${PYTHON_MULTI_USEDEP}] )
+ gtk? (
+ sound? ( dev-python/pygame[${PYTHON_MULTI_USEDEP}] )
+ dev-python/pygobject:2[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pygtk-2.12[${PYTHON_MULTI_USEDEP}]
+ gnome-base/librsvg
+ libnotify? ( dev-python/notify-python[${PYTHON_MULTI_USEDEP}] )
+ )
+ webinterface? ( dev-python/mako[${PYTHON_MULTI_USEDEP}] )
+ ')"
python_prepare_all() {
local args=(
diff --git a/net-p2p/deluge/deluge-1.3.9999.ebuild b/net-p2p/deluge/deluge-1.3.9999.ebuild
index 1be3b5719884..af10c260e9f3 100644
--- a/net-p2p/deluge/deluge-1.3.9999.ebuild
+++ b/net-p2p/deluge/deluge-1.3.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -33,31 +33,36 @@ PATCHES=(
"${FILESDIR}/${PN}-1.3.5-disable_libtorrent_internal_copy.patch"
)
-DEPEND="<net-libs/libtorrent-rasterbar-1.2[python,${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
+ $(python_gen_cond_dep '
+ <net-libs/libtorrent-rasterbar-1.2[python,${PYTHON_MULTI_USEDEP}]
+ ')
dev-util/intltool
acct-group/deluge
acct-user/deluge"
-RDEPEND="<net-libs/libtorrent-rasterbar-1.2[python,${PYTHON_USEDEP}]
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pyxdg[${PYTHON_USEDEP}]
- dev-python/setproctitle[${PYTHON_USEDEP}]
- || ( >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
- (
- >=dev-python/twisted-core-13.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-web-13.0[${PYTHON_USEDEP}]
+RDEPEND="
+ $(python_gen_cond_dep '
+ <net-libs/libtorrent-rasterbar-1.2[python,${PYTHON_MULTI_USEDEP}]
+ dev-python/chardet[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyxdg[${PYTHON_MULTI_USEDEP}]
+ dev-python/setproctitle[${PYTHON_MULTI_USEDEP}]
+ || ( >=dev-python/twisted-16.0.0[${PYTHON_MULTI_USEDEP}]
+ (
+ >=dev-python/twisted-core-13.0[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/twisted-web-13.0[${PYTHON_MULTI_USEDEP}]
+ )
)
- )
- geoip? ( dev-python/geoip-python[${PYTHON_USEDEP}] )
- gtk? (
- sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
- dev-python/pygobject:2[${PYTHON_USEDEP}]
- >=dev-python/pygtk-2.12[${PYTHON_USEDEP}]
- gnome-base/librsvg
- libnotify? ( dev-python/notify-python[${PYTHON_USEDEP}] )
- )
- webinterface? ( dev-python/mako[${PYTHON_USEDEP}] )"
+ geoip? ( dev-python/geoip-python[${PYTHON_MULTI_USEDEP}] )
+ gtk? (
+ sound? ( dev-python/pygame[${PYTHON_MULTI_USEDEP}] )
+ dev-python/pygobject:2[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pygtk-2.12[${PYTHON_MULTI_USEDEP}]
+ gnome-base/librsvg
+ libnotify? ( dev-python/notify-python[${PYTHON_MULTI_USEDEP}] )
+ )
+ webinterface? ( dev-python/mako[${PYTHON_MULTI_USEDEP}] )
+ ')"
python_prepare_all() {
local args=(
diff --git a/net-p2p/deluge/deluge-2.0.3-r2.ebuild b/net-p2p/deluge/deluge-2.0.3-r4.ebuild
index f3c58d701a9e..cf9714d16182 100644
--- a/net-p2p/deluge/deluge-2.0.3-r2.ebuild
+++ b/net-p2p/deluge/deluge-2.0.3-r4.ebuild
@@ -27,31 +27,36 @@ REQUIRED_USE="
sound? ( gtk )
"
-DEPEND="net-libs/libtorrent-rasterbar[python,${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
+ $(python_gen_cond_dep '
+ net-libs/libtorrent-rasterbar[python,${PYTHON_MULTI_USEDEP}]
+ dev-python/wheel[${PYTHON_MULTI_USEDEP}]
+ ')
dev-util/intltool
- dev-python/wheel[${PYTHON_USEDEP}]
acct-group/deluge
acct-user/deluge"
-RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/distro[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pyxdg[${PYTHON_USEDEP}]
- dev-python/rencode[${PYTHON_USEDEP}]
- dev-python/setproctitle[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/twisted-17.1.0[crypt,${PYTHON_USEDEP}]
- >=dev-python/zope-interface-4.4.2[${PYTHON_USEDEP}]
- geoip? ( dev-python/geoip-python[${PYTHON_USEDEP}] )
- gtk? (
- sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- gnome-base/librsvg
- libnotify? ( x11-libs/libnotify )
- )
- net-libs/libtorrent-rasterbar[python,${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]"
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_MULTI_USEDEP}]
+ dev-python/distro[${PYTHON_MULTI_USEDEP}]
+ dev-python/pillow[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyxdg[${PYTHON_MULTI_USEDEP}]
+ dev-python/rencode[${PYTHON_MULTI_USEDEP}]
+ dev-python/setproctitle[${PYTHON_MULTI_USEDEP}]
+ dev-python/six[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/twisted-17.1.0[crypt,${PYTHON_MULTI_USEDEP}]
+ >=dev-python/zope-interface-4.4.2[${PYTHON_MULTI_USEDEP}]
+ geoip? ( dev-python/geoip-python[${PYTHON_MULTI_USEDEP}] )
+ gtk? (
+ sound? ( dev-python/pygame[${PYTHON_MULTI_USEDEP}] )
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ gnome-base/librsvg
+ libnotify? ( x11-libs/libnotify )
+ )
+ net-libs/libtorrent-rasterbar[python,${PYTHON_MULTI_USEDEP}]
+ dev-python/mako[${PYTHON_MULTI_USEDEP}]
+ ')"
PATCHES=(
"${FILESDIR}/${PN}-2.0.3-setup.py.patch"
diff --git a/net-p2p/deluge/deluge-2.0.3-r3.ebuild b/net-p2p/deluge/deluge-2.0.3-r5.ebuild
index 8b3cbf5b4f97..3cdc92e94de4 100644
--- a/net-p2p/deluge/deluge-2.0.3-r3.ebuild
+++ b/net-p2p/deluge/deluge-2.0.3-r5.ebuild
@@ -27,31 +27,36 @@ REQUIRED_USE="
sound? ( gtk )
"
-DEPEND="net-libs/libtorrent-rasterbar[python,${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
+ $(python_gen_cond_dep '
+ net-libs/libtorrent-rasterbar[python,${PYTHON_MULTI_USEDEP}]
+ dev-python/wheel[${PYTHON_MULTI_USEDEP}]
+ ')
dev-util/intltool
- dev-python/wheel[${PYTHON_USEDEP}]
acct-group/deluge
acct-user/deluge"
-RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/distro[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pyxdg[${PYTHON_USEDEP}]
- dev-python/rencode[${PYTHON_USEDEP}]
- dev-python/setproctitle[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/twisted-17.1.0[crypt,${PYTHON_USEDEP}]
- >=dev-python/zope-interface-4.4.2[${PYTHON_USEDEP}]
- geoip? ( dev-python/geoip-python[${PYTHON_USEDEP}] )
- gtk? (
- sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- gnome-base/librsvg
- libnotify? ( x11-libs/libnotify )
- )
- net-libs/libtorrent-rasterbar[python,${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]"
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_MULTI_USEDEP}]
+ dev-python/distro[${PYTHON_MULTI_USEDEP}]
+ dev-python/pillow[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyxdg[${PYTHON_MULTI_USEDEP}]
+ dev-python/rencode[${PYTHON_MULTI_USEDEP}]
+ dev-python/setproctitle[${PYTHON_MULTI_USEDEP}]
+ dev-python/six[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/twisted-17.1.0[crypt,${PYTHON_MULTI_USEDEP}]
+ >=dev-python/zope-interface-4.4.2[${PYTHON_MULTI_USEDEP}]
+ geoip? ( dev-python/geoip-python[${PYTHON_MULTI_USEDEP}] )
+ gtk? (
+ sound? ( dev-python/pygame[${PYTHON_MULTI_USEDEP}] )
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ gnome-base/librsvg
+ libnotify? ( x11-libs/libnotify )
+ )
+ net-libs/libtorrent-rasterbar[python,${PYTHON_MULTI_USEDEP}]
+ dev-python/mako[${PYTHON_MULTI_USEDEP}]
+ ')"
PATCHES=(
"${FILESDIR}/${PN}-2.0.3-setup.py.patch"
diff --git a/net-p2p/deluge/deluge-9999.ebuild b/net-p2p/deluge/deluge-9999.ebuild
index d1806e7558e9..9bf5ba2d72ba 100644
--- a/net-p2p/deluge/deluge-9999.ebuild
+++ b/net-p2p/deluge/deluge-9999.ebuild
@@ -27,31 +27,36 @@ REQUIRED_USE="
sound? ( gtk )
"
-DEPEND="net-libs/libtorrent-rasterbar[python,${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
+ $(python_gen_cond_dep '
+ net-libs/libtorrent-rasterbar[python,${PYTHON_MULTI_USEDEP}]
+ dev-python/wheel[${PYTHON_MULTI_USEDEP}]
+ ')
dev-util/intltool
- dev-python/wheel[${PYTHON_USEDEP}]
acct-group/deluge
acct-user/deluge"
-RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/distro[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pyxdg[${PYTHON_USEDEP}]
- dev-python/rencode[${PYTHON_USEDEP}]
- dev-python/setproctitle[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/twisted-17.1.0[crypt,${PYTHON_USEDEP}]
- >=dev-python/zope-interface-4.4.2[${PYTHON_USEDEP}]
- geoip? ( dev-python/geoip-python[${PYTHON_USEDEP}] )
- gtk? (
- sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- gnome-base/librsvg
- libnotify? ( x11-libs/libnotify )
- )
- net-libs/libtorrent-rasterbar[python,${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]"
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_MULTI_USEDEP}]
+ dev-python/distro[${PYTHON_MULTI_USEDEP}]
+ dev-python/pillow[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyxdg[${PYTHON_MULTI_USEDEP}]
+ dev-python/rencode[${PYTHON_MULTI_USEDEP}]
+ dev-python/setproctitle[${PYTHON_MULTI_USEDEP}]
+ dev-python/six[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/twisted-17.1.0[crypt,${PYTHON_MULTI_USEDEP}]
+ >=dev-python/zope-interface-4.4.2[${PYTHON_MULTI_USEDEP}]
+ geoip? ( dev-python/geoip-python[${PYTHON_MULTI_USEDEP}] )
+ gtk? (
+ sound? ( dev-python/pygame[${PYTHON_MULTI_USEDEP}] )
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ gnome-base/librsvg
+ libnotify? ( x11-libs/libnotify )
+ )
+ net-libs/libtorrent-rasterbar[python,${PYTHON_MULTI_USEDEP}]
+ dev-python/mako[${PYTHON_MULTI_USEDEP}]
+ ')"
PATCHES=(
"${FILESDIR}/${PN}-2.0.3-setup.py.patch"