summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-12-16 12:15:26 -0500
committerAnthony G. Basile <blueness@gentoo.org>2015-12-16 12:15:56 -0500
commit88eb1c762bfa9a47000bf633cf083deaa84ce25d (patch)
treea2da0e17b6867d1842c1fe2a9a00367001972b64 /net-p2p
parentnet-p2p/litecoin-qt: fix for API change in miniunpnc, bug #567080. (diff)
downloadgentoo-88eb1c762bfa9a47000bf633cf083deaa84ce25d.tar.gz
gentoo-88eb1c762bfa9a47000bf633cf083deaa84ce25d.tar.bz2
gentoo-88eb1c762bfa9a47000bf633cf083deaa84ce25d.zip
net-p2p/litecoind: fix for API change in miniunpnc, bug #567080.
Package-Manager: portage-2.2.24
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/litecoind/files/litecoin-miniupnpc-abi.patch19
-rw-r--r--net-p2p/litecoind/litecoind-0.10.2.2-r1.ebuild98
-rw-r--r--net-p2p/litecoind/litecoind-0.10.2.2-r3.ebuild (renamed from net-p2p/litecoind/litecoind-0.10.2.2-r2.ebuild)5
3 files changed, 22 insertions, 100 deletions
diff --git a/net-p2p/litecoind/files/litecoin-miniupnpc-abi.patch b/net-p2p/litecoind/files/litecoin-miniupnpc-abi.patch
new file mode 100644
index 000000000000..7315ea9d2a45
--- /dev/null
+++ b/net-p2p/litecoind/files/litecoin-miniupnpc-abi.patch
@@ -0,0 +1,19 @@
+diff -Nuar litecoin-0.10.2.2/src/net.cpp litecoin-0.10.2.2-fix/src/net.cpp
+--- litecoin-0.10.2.2/src/net.cpp 2015-06-15 08:51:30.000000000 +0000
++++ litecoin-0.10.2.2-fix/src/net.cpp 2015-12-16 12:38:52.881533970 +0000
+@@ -1020,10 +1020,14 @@
+ #ifndef UPNPDISCOVER_SUCCESS
+ /* miniupnpc 1.5 */
+ devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0);
+-#else
++#elif MINIUPNPC_API_VERSION < 14
+ /* miniupnpc 1.6 */
+ int error = 0;
+ devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0, 0, &error);
++#else
++ /* miniupnpc 1.9.20150730 */
++ int error = 0;
++ devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0, 0, 2, &error);
+ #endif
+
+ struct UPNPUrls urls; \ No newline at end of file
diff --git a/net-p2p/litecoind/litecoind-0.10.2.2-r1.ebuild b/net-p2p/litecoind/litecoind-0.10.2.2-r1.ebuild
deleted file mode 100644
index 07e92b83874e..000000000000
--- a/net-p2p/litecoind/litecoind-0.10.2.2-r1.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-DB_VER="4.8"
-
-inherit autotools db-use eutils systemd user
-
-MyPV="${PV/_/-}"
-MyPN="litecoin"
-MyP="${MyPN}-${MyPV}"
-
-DESCRIPTION="P2P Internet currency based on Bitcoin but easier to mine"
-HOMEPAGE="https://litecoin.org/"
-SRC_URI="https://github.com/${MyPN}-project/${MyPN}/archive/v${MyPV}.tar.gz -> ${MyP}.tar.gz"
-
-LICENSE="MIT ISC GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="logrotate upnp +wallet"
-
-RDEPEND="
- dev-libs/boost[threads(+)]
- dev-libs/openssl:0[-bindist]
- logrotate? ( app-admin/logrotate )
- upnp? ( net-libs/miniupnpc )
- sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
- <=dev-libs/leveldb-1.15.0-r1
-"
-DEPEND="${RDEPEND}
- >=app-shells/bash-4.1
- sys-apps/sed
-"
-
-S="${WORKDIR}/${MyP}"
-
-pkg_setup() {
- local UG='litecoin'
- enewgroup "${UG}"
- enewuser "${UG}" -1 -1 /var/lib/litecoin "${UG}"
-}
-
-src_prepare() {
- epatch "${FILESDIR}/0.9.0-sys_leveldb.patch"
- eautoreconf
- rm -r src/leveldb
-}
-
-src_configure() {
- local my_econf=
- if use upnp; then
- my_econf="${my_econf} --with-miniupnpc --enable-upnp-default"
- else
- my_econf="${my_econf} --without-miniupnpc --disable-upnp-default"
- fi
- econf \
- $(use_enable wallet)\
- --disable-ccache \
- --disable-static \
- --disable-tests \
- --with-system-leveldb \
- --with-system-libsecp256k1 \
- --without-libs \
- --with-daemon \
- --without-gui \
- --without-qrencode \
- ${my_econf}
-}
-
-src_install() {
- default
-
- insinto /etc/litecoin
- doins "${FILESDIR}/litecoin.conf"
- fowners litecoin:litecoin /etc/litecoin/litecoin.conf
- fperms 600 /etc/litecoin/litecoin.conf
-
- newconfd "${FILESDIR}/litecoin.confd" ${PN}
- newinitd "${FILESDIR}/litecoin.initd-r1" ${PN}
- systemd_dounit "${FILESDIR}/litecoin.service"
-
- keepdir /var/lib/litecoin/.litecoin
- fperms 700 /var/lib/litecoin
- fowners litecoin:litecoin /var/lib/litecoin/
- fowners litecoin:litecoin /var/lib/litecoin/.litecoin
- dosym /etc/litecoin/litecoin.conf /var/lib/litecoin/.litecoin/litecoin.conf
-
- dodoc doc/README.md doc/release-notes.md
- newman contrib/debian/manpages/bitcoind.1 litecoind.1
- newman contrib/debian/manpages/bitcoin.conf.5 litecoin.conf.5
-
- if use logrotate; then
- insinto /etc/logrotate.d
- newins "${FILESDIR}/litecoind.logrotate" litecoind
- fi
-}
diff --git a/net-p2p/litecoind/litecoind-0.10.2.2-r2.ebuild b/net-p2p/litecoind/litecoind-0.10.2.2-r3.ebuild
index 5951608269e1..9c14a513bc6d 100644
--- a/net-p2p/litecoind/litecoind-0.10.2.2-r2.ebuild
+++ b/net-p2p/litecoind/litecoind-0.10.2.2-r3.ebuild
@@ -43,8 +43,9 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}/0.9.0-sys_leveldb.patch"
- epatch "${FILESDIR}/${P}-memenv_h.patch"
+ epatch "${FILESDIR}"/0.9.0-sys_leveldb.patch
+ epatch "${FILESDIR}"/litecoind-0.10.2.2-memenv_h.patch
+ epatch "${FILESDIR}"/litecoin-miniupnpc-abi.patch
eautoreconf
rm -r src/leveldb
}