summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-02-06 11:38:18 -0500
committerCraig Andrews <candrews@gentoo.org>2020-02-06 11:38:40 -0500
commit95d7331afac15e7e66e2e6ebc90b9385cc66bb8c (patch)
tree22dc097d5b80e5fac9e753b5434b651dfe2f29c6 /net-p2p
parentmedia-plugins/kodi-audiodecoder-nosefart: 2.0.2 version bump (diff)
downloadgentoo-95d7331afac15e7e66e2e6ebc90b9385cc66bb8c.tar.gz
gentoo-95d7331afac15e7e66e2e6ebc90b9385cc66bb8c.tar.bz2
gentoo-95d7331afac15e7e66e2e6ebc90b9385cc66bb8c.zip
net-p2p/cpuminer-opt: 3.12.0 version bump
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.12.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index ba5cc3b08fa1..0d6f4fc3ff3c 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1 +1,2 @@
DIST cpuminer-opt-3.11.9.tar.gz 1871215 BLAKE2B 3cd19225d4e2b4ab26721069d83f6d568c48ca12fa94ced35024420429000099f8db0e8c69e46617738238d9ab969ef39e3ef555731c4618a7b7b6c88d438c58 SHA512 d1a8f18769970a05df8da454f1755fda593dc0dfb2484855fb447dca25484254cefdbd31e19917b13195519c0e5cbf91fbe644f2d27300ad2db6c1ae52d5125b
+DIST cpuminer-opt-3.12.0.tar.gz 1808901 BLAKE2B 25002c7f8285fead4fcc8ea6276bad030498382a93148c55d7e9627929c6cf711c0599a0bf7b88911be841504efe0a9f79f152dad25f06b8cf43b61f0037f3fd SHA512 05b3420b6b935dc67aa35c14db6a7aad4f279fa3814c2a91ee1ecfe7584a5a0b49f18d0b42208f4a7c74159700271f0269d1cdabd808bf19dd6a2b9e530b2725
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.12.0.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.12.0.ebuild
new file mode 100644
index 000000000000..a5d436b3b8b8
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.12.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ >=net-misc/curl-7.15[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}