summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-02-19 11:44:39 -0500
committerCraig Andrews <candrews@gentoo.org>2020-02-19 11:45:07 -0500
commita28419955b7984d426610a91ec03755de9c0e0c5 (patch)
tree663ed99ea9bf0af5d748e64b1851066728fb5a20 /net-p2p
parentsys-apps/gptfdisk: stable 1.0.4 for sparc, bug #710018 (diff)
downloadgentoo-a28419955b7984d426610a91ec03755de9c0e0c5.tar.gz
gentoo-a28419955b7984d426610a91ec03755de9c0e0c5.tar.bz2
gentoo-a28419955b7984d426610a91ec03755de9c0e0c5.zip
net-p2p/cpuminer-opt: 3.12.3.1 version bump
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.12.3.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 49ad01f354a0..a6af048af650 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1,3 +1,4 @@
DIST cpuminer-opt-3.12.1.tar.gz 1809074 BLAKE2B 2c19cba4dc070286d7fe39b53b61177b64c3d873bbcefa359c62f4cdaa8b685fa40f2ef61a1fce9fba57902ba3399cd3b45816e932362f2633ce3ca174ad2b41 SHA512 98c84e8057a9c31cfa65daba32f43c7a7d9225878dcce07c740fac563225494c901f15bdf0450e50d857918dbc01861ddfd39ead9d44f8038fe866bfa3ef69e1
DIST cpuminer-opt-3.12.13.tar.gz 1809807 BLAKE2B c971153fc1099dc29ae93ab341e905b3d0252d02468e0f125692a38d00121f82a2825d61e8303e45f4b41f64280d780a02f742eb61d117601a6ce47db57d4d2d SHA512 830371c4e2931101d33d124c86733e9f079ace5b4b59e3b5149db0655c93031dcbbb2dd370d4729b7e697670117c0b6874214a8aa569dcca92c6750dbc88a8b8
DIST cpuminer-opt-3.12.2.tar.gz 1809424 BLAKE2B fedec681166de95e18d41e4c61ec75a9e1ea1fc1cdb656cebcb303a637a01eb3aba9e0c5cbb5cc710be6a2191dcbef0b1a2c00f0ce349064b25471eac5035c26 SHA512 f8a9c71d673f68418164cc1f0bd7c80b4e5d246b21a8f54432ad9fc87c1962a0ab0a96372018e2d1da55d084b6ce9dcae58dd3f7a0b0e62e595a805fefdb5a10
+DIST cpuminer-opt-3.12.3.1.tar.gz 1809916 BLAKE2B 5ee9f9b1bdcadf9a069fbf46cdad26331504147118b4d79c281ef8322eb3901920b89548afe4b032982668b454db58e658bbb952031fb2f5f764e7e013be006e SHA512 0e6069e7d85b6f2632da919f79183e15dc89ac8ac6c9524a59459bd0c8c4c02fd9b6669434c7f17475f713075763f8a7b939f955866ba4a0b2b1764758096635
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.12.3.1.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.12.3.1.ebuild
new file mode 100644
index 000000000000..a5d436b3b8b8
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.12.3.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ >=net-misc/curl-7.15[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}