summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-09-06 21:23:51 +0200
committerDavid Seifert <soap@gentoo.org>2017-09-16 12:12:46 +0200
commitb77ff688d29010b03643eb7963ecf4c71c2f2d0e (patch)
treec240105cf99eb1fd1aa0a9b3d1e28c07f09e3ed1 /net-p2p
parentsys-devel/kgcc64: update comment about the arches needing kgcc64 (diff)
downloadgentoo-b77ff688d29010b03643eb7963ecf4c71c2f2d0e.tar.gz
gentoo-b77ff688d29010b03643eb7963ecf4c71c2f2d0e.tar.bz2
gentoo-b77ff688d29010b03643eb7963ecf4c71c2f2d0e.zip
net-p2p/airdcpp-webclient: bump to 2.2.0, fixes build with boost 1.65.0
Closes: https://bugs.gentoo.org/630092 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/airdcpp-webclient/Manifest1
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-2.2.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index e223aa66ff5d..e82bac8901ea 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1,3 +1,4 @@
DIST airdcpp-webclient-1.4.1.tar.gz 743631 SHA256 9acb61366c91a7aaa03cae58e9aee28ccac05ffe9dff0ec947836fa81967f27f SHA512 7b973251574cb5b49942efa868cef9f689fcf8d804be632ad17c445be98ab55ca9973c5fe9dce052d542006d47a7850af7d236953010c2c0e3158c54e448afe1 WHIRLPOOL e43ccfddc50dbdd0ce8a3cd5b00fc4c844ed69051967d67cca9c9c72b073227d1d20ac510d34b07161c231c7c7d69b945d60872d8756a0ef2c91dfe4a843fe06
DIST airdcpp-webclient-2.0.1.tar.gz 843348 SHA256 312466c20b6c3125b6bf88b26f23618f67546722bb0372089537c5a88cc3460b SHA512 2c31712816a59560f248f42b3ad3ffe5d2f76a64860bf515a537b79dda5a579bac17d5d8ba46d9d57554a0b93b9384696a299b2f2096e05c62ea4b97e42d06bc WHIRLPOOL e78d998d8398eb705599ed0f249242d460586288c5649b810606321334a7ea66bd2cb9f119789eec19038e1e3d9ce376a93e96bd18fe15bba10d7a80c97ee580
DIST airdcpp-webclient-2.1.0.tar.gz 844435 SHA256 a8d8a33e3974d23009359709da0bee85e8983e3ea1fe78f21a867078f93b81fa SHA512 755555d30183e772ad5d2e38a813f548e3322ca034b759200f289a834ae21b64f56102f57a13832a837e8a11324efe74a860e941a0f28a02d1f843aed92a328f WHIRLPOOL 5a0a61bcf0ad1de1706786fc2080aeba0ae634386957876a20d1ca638d3fc8b724f5c866d59588f4958a6010fc192d474f1cfe7ff04d4403106ba631b800739b
+DIST airdcpp-webclient-2.2.0.tar.gz 844968 SHA256 77cde1acd8730370e87e3546f9895bb993a459ad8f70e1713803ec3ba0a849cb SHA512 a7fc608109ee5823f844bd575d9355d0cbb4094c89e5dcba522018685d969974e82d3dea56bd334591a424010e0b43858f227e2bb66d738c0151c1456175800d WHIRLPOOL 040076d1fd2d7973ccaa6dd0935c0f2b1828c6e4d3bff6de362fd53656d54bf9a9c5733c23fbee35fd6ece897fd5a2ca2b277ceeda51b03c66277f2c81759eb3
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-2.2.0.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.2.0.ebuild
new file mode 100644
index 000000000000..fd8f46fe630b
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.2.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+
+inherit cmake-utils python-any-r1 user
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://airdcpp-web.github.io/"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="nat-pmp +tbb +webui"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost:=
+ dev-libs/geoip
+ dev-libs/leveldb:=
+ dev-libs/openssl:0=[-bindist]
+ net-libs/miniupnpc:=
+ sys-libs/zlib:=
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp:= )
+ tbb? ( dev-cpp/tbb:= )
+"
+DEPEND="
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+ ${RDEPEND}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ enewgroup airdcppd
+ enewuser airdcppd -1 -1 /var/lib/airdcppd airdcppd
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_WEB_UI=OFF
+ -DENABLE_NATPMP=$(usex nat-pmp)
+ -DENABLE_TBB=$(usex tbb)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ keepdir /var/lib/airdcppd
+ fowners airdcppd:airdcppd /var/lib/airdcppd
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}