summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathy Vanvoorden <mathy@vanvoorden.be>2016-10-11 14:34:30 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-12 09:36:45 +0200
commitcb7d65aae5a595e7b9d44b627988ea0c8066ee71 (patch)
tree9c56681a3d4f784381bf8dfbf3e353d73be36c95 /net-p2p
parentdev-lang/solidity: New package (diff)
downloadgentoo-cb7d65aae5a595e7b9d44b627988ea0c8066ee71.tar.gz
gentoo-cb7d65aae5a595e7b9d44b627988ea0c8066ee71.tar.bz2
gentoo-cb7d65aae5a595e7b9d44b627988ea0c8066ee71.zip
net-p2p/go-ethereum: add opencl USE-flag
Adds support for mining with GPU Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=596720 Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2532 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/go-ethereum/go-ethereum-1.4.17-r1.ebuild (renamed from net-p2p/go-ethereum/go-ethereum-1.4.17.ebuild)8
-rw-r--r--net-p2p/go-ethereum/metadata.xml1
2 files changed, 7 insertions, 2 deletions
diff --git a/net-p2p/go-ethereum/go-ethereum-1.4.17.ebuild b/net-p2p/go-ethereum/go-ethereum-1.4.17-r1.ebuild
index e5c4fb7ef62a..28bfc26b14b2 100644
--- a/net-p2p/go-ethereum/go-ethereum-1.4.17.ebuild
+++ b/net-p2p/go-ethereum/go-ethereum-1.4.17-r1.ebuild
@@ -11,12 +11,16 @@ SRC_URI="https://github.com/ethereum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3+ LGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="evm"
+IUSE="evm opencl"
-DEPEND="dev-lang/go:="
+DEPEND="dev-lang/go:=
+ opencl? ( virtual/opencl )
+"
RDEPEND="${DEPEND}"
src_compile() {
+ use opencl && export GO_OPENCL=true
+
emake geth
use evm && emake evm
}
diff --git a/net-p2p/go-ethereum/metadata.xml b/net-p2p/go-ethereum/metadata.xml
index d54331023213..8a476b0cf138 100644
--- a/net-p2p/go-ethereum/metadata.xml
+++ b/net-p2p/go-ethereum/metadata.xml
@@ -11,5 +11,6 @@
</maintainer>
<use>
<flag name="evm">Build Ethereum Virtual Machine (EVM)</flag>
+ <flag name="opencl">Add OpenCL GPU mining support</flag>
</use>
</pkgmetadata>