summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-01-11 12:18:58 +0100
committerLouis Sautier <sbraz@gentoo.org>2021-01-11 12:23:53 +0100
commitd26f86403d350ca26539da909c04cea65197b747 (patch)
treeeda4d6daf0743efe280bd1757a7606608dedcd93 /net-p2p
parentsys-apps/fwupd: Removed old (diff)
downloadgentoo-d26f86403d350ca26539da909c04cea65197b747.tar.gz
gentoo-d26f86403d350ca26539da909c04cea65197b747.tar.bz2
gentoo-d26f86403d350ca26539da909c04cea65197b747.zip
net-p2p/airdcpp-webclient: bump to 2.11.0
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/airdcpp-webclient/Manifest1
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-2.11.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index 31c9e74ab0be..847f39f3e317 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1,2 +1,3 @@
DIST airdcpp-webclient-2.10.0.tar.gz 963410 BLAKE2B 9cbc04d023d9478d48b177cfb457cdaff11a8079388078125ccecf5936cbac8e22aea3cddae9dd21b76b6d24d586ae4799bf2a8e67929d1134a2218a57aa9c3b SHA512 c80ec28198550846feda6d3dfd01ea0e0b402cab6753c1f7976df4bda0d8a8a2124d1ae7a437dbb15446665ec199decf897e49edd6aaf7f3983e7b7e7dc645e5
DIST airdcpp-webclient-2.10.1.tar.gz 964433 BLAKE2B aa0db1c199e0546a35dddb7750ae9b2723afe09ab77a3ee17c02a1f592afc4075eab1017ea4114f07ee2e4d363aabfde510647f4e25569835312f120677cb1c6 SHA512 82a0ab406fa5861deea5be6a06682f2a756d3140ec85faf0cd1f9c5ddbae3a63acdad560f7196e7a25de0183e6647954ad7428fc327f81578a4b64a0e2ce088f
+DIST airdcpp-webclient-2.11.0.tar.gz 967326 BLAKE2B 47d257e47c332b4fd5351a680f0585360cb7329cd1bcf3c478d0a7847adbee68c024af7136eeb3b551188d3af7c4a6db2257eefaca7f82ee4670667a4a6e3e63 SHA512 926457e76b6bd29e0124c519b67d9e0f3cee48192c1b56e073b84d65f0171d53a7a4dbaf55e100f0685e01116935f4e4e2c193dab0ef0bed08d8101e12c33b82
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-2.11.0.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.11.0.ebuild
new file mode 100644
index 000000000000..3676756cac0d
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.11.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+
+inherit cmake python-any-r1 systemd
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://airdcpp-web.github.io/"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="debug nat-pmp +tbb +webui"
+
+RDEPEND="
+ acct-user/airdcppd
+ acct-group/airdcppd
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost:=
+ dev-libs/leveldb:=
+ dev-libs/libmaxminddb:=
+ dev-libs/openssl:0=[-bindist]
+ net-libs/miniupnpc:=
+ sys-libs/zlib
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp:= )
+ tbb? ( dev-cpp/tbb:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_NATPMP=$(usex nat-pmp)
+ -DENABLE_TBB=$(usex tbb)
+ -DINSTALL_WEB_UI=OFF
+ )
+ CMAKE_BUILD_TYPE=$(usex debug Debug Gentoo) cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ systemd_dounit "${FILESDIR}/airdcppd.service"
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}