summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLorenzo Porta <vindex17@outlook.it>2016-09-17 15:48:50 +0200
committerDavide Pesavento <pesa@gentoo.org>2016-10-16 01:17:45 +0200
commitf2e28b9db6bafd7cce980ca2312cd7af392d60be (patch)
treea0f22c16cb327caac2dede24a10f33441c46e86b /net-p2p
parentdev-ruby/sprockets: Remove old (diff)
downloadgentoo-f2e28b9db6bafd7cce980ca2312cd7af392d60be.tar.gz
gentoo-f2e28b9db6bafd7cce980ca2312cd7af392d60be.tar.bz2
gentoo-f2e28b9db6bafd7cce980ca2312cd7af392d60be.zip
net-p2p/qbittorrent: version bump
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/qbittorrent-3.3.7.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index aa28abade8cf..f20d075d85af 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -2,3 +2,4 @@ DIST qbittorrent-3.1.12.tar.xz 2465744 SHA256 d5d5b27958297f0b14cf03af8dd24a0d2a
DIST qbittorrent-3.1.9.2.tar.xz 2231708 SHA256 b07ccdbe1ae079f781c62aff21d47183ae35a8d4e96f43f90503978d1830a361 SHA512 8437fb695fb720132d131e44727c28af46c651576d5321423142c190120c59cc6439f5df2e90486274956d253db657fcbd217a834e3ca53d7681919fee7a2504 WHIRLPOOL e4b00027a57fbce49a9ddcaf6e60fccfabb65393531620afa0416249148e9e17d43398a1016fcf04695d0fa7d0a7b970e5beee0a4ab4e6ff06e6f8c23c90154f
DIST qbittorrent-3.3.3.tar.xz 2782616 SHA256 9c8d8bdc3fb2632019cb3ee5f811baaa41b41fe7ce542c753c6771bcc110db53 SHA512 2dd954e2518a2a99e271bf62d6db38a4e1788bb91c8b7552b94aab25dfb7b6cc7b4eb0ae49bb50d524127e8a357ea07b022c3a6e3b0593f6d2e7a2ce3abf6260 WHIRLPOOL e794a50215f33c2088b4782fd8733e11c33b42a45b5df2424bdf0fcee3c0929445f0d47b1e8b3526341f4ee9a4b8cd081da54a0c3019f79dea9b50a3bb5dcbad
DIST qbittorrent-3.3.4.tar.xz 2841268 SHA256 c0d0d4b72c240f113b59a061146803bc1b7926d3d7f39b06b50a4d26f5ad91b8 SHA512 5cb94b6463d4baa1a994bee7dd5f9aee823d86d5428aff2719011b5f5340db5aaf35436f4f3be7c773e5560eb5f8ea12ea889505bfd40071401dd7ebf9835ec1 WHIRLPOOL 4406703fc459c9115e1d2e04e2a6a69149f7359fabaab284001bd1fec9fbd21c0aadca6836562d09d80390abf42388c864f6bc206080ee50f9c8ab4b80cca4e8
+DIST qbittorrent-3.3.7.tar.xz 2884792 SHA256 72dc824a90fadc0825e6be6f1c215e38f976262c7f83b625061d542b2b664c40 SHA512 c33ae47bd78e79197fd499e9541ce20a30c0ee582c6696f72b792a46324a42bffbe2140f6dcb89c05d9366b7332845e108c661c0458e94ca5739cfc71be4dafc WHIRLPOOL 753efd5e30c725d77e241bfc4cee63f089109b4a85bab5224e5445d141605c07bb8873531245d17f577252ae1d90041457848e9290ecb2384d96f2a20bbf6f66
diff --git a/net-p2p/qbittorrent/qbittorrent-3.3.7.ebuild b/net-p2p/qbittorrent/qbittorrent-3.3.7.ebuild
new file mode 100644
index 000000000000..70a4b9642c57
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-3.3.7.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit flag-o-matic qmake-utils
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+else
+ MY_P=${P/_}
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+ S=${WORKDIR}/${MY_P}
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus debug +qt5 webui +X"
+REQUIRED_USE="
+ dbus? ( X )
+"
+
+RDEPEND="
+ dev-libs/boost:=
+ >=net-libs/rb_libtorrent-1.0.6
+ sys-libs/zlib
+ !qt5? (
+ >=dev-libs/qjson-0.8.1[qt4(+)]
+ dev-qt/qtcore:4[ssl]
+ >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt4,X?]
+ dbus? ( dev-qt/qtdbus:4 )
+ X? ( dev-qt/qtgui:4 )
+ )
+ qt5? (
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt5,X?]
+ dev-qt/qtxml:5
+ dbus? ( dev-qt/qtdbus:5 )
+ X? (
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+ )
+"
+DEPEND="${RDEPEND}
+ qt5? ( dev-qt/linguist-tools:5 )
+ virtual/pkgconfig
+"
+
+DOCS=(AUTHORS Changelog CONTRIBUTING.md README.md TODO)
+
+src_configure() {
+ # workaround build issue with older boost
+ # https://github.com/qbittorrent/qBittorrent/issues/4112
+ if has_version '<dev-libs/boost-1.58'; then
+ append-cppflags -DBOOST_NO_CXX11_REF_QUALIFIERS
+ fi
+
+ econf \
+ --with-qjson=system \
+ --with-qtsingleapplication=system \
+ $(use_enable dbus qt-dbus) \
+ $(use_enable debug) \
+ $(use_enable webui) \
+ $(use_enable X gui) \
+ $(use_enable !X systemd) \
+ $(use_with !qt5 qt4)
+
+ if use qt5; then
+ eqmake5
+ else
+ eqmake4
+ fi
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}