summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-07-10 23:19:21 +0100
committerMarek Szuba <marecki@gentoo.org>2023-07-11 00:04:20 +0100
commitfa8c5289990a70406ac4550a2d9054d2a4a6ee74 (patch)
tree636f299d09ded03d567d6dedb37c286b10f7b13a /net-p2p
parentapp-misc/gramps: switch from distutils-r1 to python-single-r1 (diff)
downloadgentoo-fa8c5289990a70406ac4550a2d9054d2a4a6ee74.tar.gz
gentoo-fa8c5289990a70406ac4550a2d9054d2a4a6ee74.tar.bz2
gentoo-fa8c5289990a70406ac4550a2d9054d2a4a6ee74.zip
net-p2p/syncthing: add 1.23.6
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/syncthing/Manifest1
-rw-r--r--net-p2p/syncthing/syncthing-1.23.6.ebuild112
2 files changed, 113 insertions, 0 deletions
diff --git a/net-p2p/syncthing/Manifest b/net-p2p/syncthing/Manifest
index 4a1eb75f9699..f955a9cb7c60 100644
--- a/net-p2p/syncthing/Manifest
+++ b/net-p2p/syncthing/Manifest
@@ -1 +1,2 @@
DIST syncthing-1.23.5.tar.gz 14196275 BLAKE2B e9d44ed83546ea28e474379c7b3141e447e4f595cf8587220fe76d64844b1ee57551f56b06a7244afc3af45728c19bd76b6ba923da03983dc7ae9799ac36d9a9 SHA512 ef41c7bf8e693e3db5ea7c3cd645580a89131cc0fb48e12a50a24af28c86533bf973c58daea7cda5822544602c366a21f299c88dcd601e3913b6a08d5f4564dc
+DIST syncthing-1.23.6.tar.gz 14213659 BLAKE2B ef4f1a8bbf5bce6c7bc9bf80f55c875b5edfd5c10481676ddff9b1579afc518723a28d83424e62a178192f795b30526eca912a3e0d20be1901b065c431acf139 SHA512 32162bcf1677015d3359a141968c9e3544c8bd631905489a11bf79f45fa4ae442e8dc0f24c19c2b55defd88b3d5b56ae35d352aac9c09f6b82c50fd8b27fc796
diff --git a/net-p2p/syncthing/syncthing-1.23.6.ebuild b/net-p2p/syncthing/syncthing-1.23.6.ebuild
new file mode 100644
index 000000000000..d8e3bf08df7a
--- /dev/null
+++ b/net-p2p/syncthing/syncthing-1.23.6.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop go-module systemd xdg-utils
+
+DESCRIPTION="Open Source Continuous File Synchronization"
+HOMEPAGE="https://syncthing.net"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${PN}-source-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0 Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~x86"
+IUSE="selinux tools"
+
+RDEPEND="acct-group/syncthing
+ acct-user/syncthing
+ tools? ( >=acct-user/stdiscosrv-1
+ >=acct-user/strelaysrv-1 )
+ selinux? ( sec-policy/selinux-syncthing )"
+
+DOCS=( README.md AUTHORS CONTRIBUTING.md )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.4-TestIssue5063_timeout.patch
+ "${FILESDIR}"/${PN}-1.18.4-tool_users.patch
+ "${FILESDIR}"/${PN}-1.23.2-tests_race.patch
+)
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ # Bug #679280
+ xdg_environment_reset
+
+ default
+ sed -i \
+ 's|^ExecStart=.*|ExecStart=/usr/libexec/syncthing/stdiscosrv|' \
+ cmd/stdiscosrv/etc/linux-systemd/stdiscosrv.service \
+ || die
+ sed -i \
+ 's|^ExecStart=.*|ExecStart=/usr/libexec/syncthing/strelaysrv|' \
+ cmd/strelaysrv/etc/linux-systemd/strelaysrv.service \
+ || die
+}
+
+src_compile() {
+ GOARCH= go run build.go -version "v${PV}" -no-upgrade -build-out=bin/ \
+ ${GOARCH:+-goarch="${GOARCH}"} \
+ build $(usex tools "all" "") || die "build failed"
+}
+
+src_test() {
+ go run build.go test || die "test failed"
+}
+
+src_install() {
+ local icon_size
+
+ doman man/*.[157]
+ einstalldocs
+
+ dobin bin/syncthing
+
+ domenu etc/linux-desktop/*.desktop
+ for icon_size in 32 64 128 256 512; do
+ newicon -s ${icon_size} assets/logo-${icon_size}.png ${PN}.png
+ done
+ newicon -s scalable assets/logo-only.svg ${PN}.svg
+
+ if use tools; then
+ exeinto /usr/libexec/syncthing
+ local exe
+ for exe in bin/* ; do
+ [[ "${exe}" == "bin/syncthing" ]] || doexe "${exe}"
+ done
+ fi
+
+ systemd_dounit etc/linux-systemd/system/${PN}{@,-resume}.service
+ systemd_douserunit etc/linux-systemd/user/${PN}.service
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ newinitd "${FILESDIR}"/${PN}.initd-r2 ${PN}
+
+ keepdir /var/log/${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+
+ if use tools; then
+ systemd_dounit cmd/stdiscosrv/etc/linux-systemd/stdiscosrv.service
+ newconfd "${FILESDIR}"/stdiscosrv.confd stdiscosrv
+ newinitd "${FILESDIR}"/stdiscosrv.initd-r1 stdiscosrv
+
+ systemd_dounit cmd/strelaysrv/etc/linux-systemd/strelaysrv.service
+ newconfd "${FILESDIR}"/strelaysrv.confd strelaysrv
+ newinitd "${FILESDIR}"/strelaysrv.initd-r1 strelaysrv
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/stdiscosrv.logrotate strelaysrv
+ newins "${FILESDIR}"/strelaysrv.logrotate strelaysrv
+ fi
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}