summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-11-28 11:36:32 -0500
committerAaron Bauman <bman@gentoo.org>2020-11-28 11:44:48 -0500
commit32e023d44e3ce18d802425a2dfe49447c8688d90 (patch)
treec6fa9520543f4724f422f87e5dfc8d8aaf66c6d7 /net-print/c2esp/c2esp-26.ebuild
parentnet-nntp/slrn: drop old (diff)
downloadgentoo-32e023d44e3ce18d802425a2dfe49447c8688d90.tar.gz
gentoo-32e023d44e3ce18d802425a2dfe49447c8688d90.tar.bz2
gentoo-32e023d44e3ce18d802425a2dfe49447c8688d90.zip
net-print/c2esp: drop old
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'net-print/c2esp/c2esp-26.ebuild')
-rw-r--r--net-print/c2esp/c2esp-26.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/net-print/c2esp/c2esp-26.ebuild b/net-print/c2esp/c2esp-26.ebuild
deleted file mode 100644
index 1619b47f90b3..000000000000
--- a/net-print/c2esp/c2esp-26.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-MY_P=${PN}${PV}
-
-DESCRIPTION="A cups filter for Kodak ESP printers"
-HOMEPAGE="http://cupsdriverkodak.sf.net/"
-SRC_URI="mirror://sourceforge/cupsdriverkodak/files/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-
-S=${WORKDIR}/${MY_P}
-
-DEPEND=">=media-libs/jbigkit-2.0-r1
- >=net-print/cups-1.4"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-ldflags-cppflags.patch
-
- # Remove embedded media-libs/jbigkit
- rm -f *jbig* || die
-
- # Remove the embedded jbig files from the Makefile's dependencies:
- sed -i \
- -e '/^[a-z0-9.]*:/s/\$(LIBJBG[[:digit:]]*)//g' \
- -e '/^[a-z0-9.]*:/s/jbig[^ ]*\.h//g' \
- -e '/\$(INSTALL).*COPYING/d' \
- Makefile || die
-
- # Use Gentoo-style cups paths
- sed -i -e s,/usr/lib/cups/filter,/usr/libexec/cups/filter,g ppd/*.ppd || die
-}
-
-src_compile() {
- emake -j1 CC="$(tc-getCC)" LIBJBG=-ljbig LIBJBG85=-ljbig85
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- FILTERBIN="${D}"/usr/libexec/cups/filter \
- DOCDIR="${ED}"/usr/share/doc/${PF} \
- install
-}