summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-29 17:40:04 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-29 17:40:04 +0100
commit40b5831adadd55442b152c2080d8871cb7cfc6e9 (patch)
tree6450d26937e00e88b7db719e92b1a289e8153be9 /net-print/cndrvcups-common-lb/cndrvcups-common-lb-3.70.ebuild
parentmedia-sound/dvda-author: Respect AR (diff)
downloadgentoo-40b5831adadd55442b152c2080d8871cb7cfc6e9.tar.gz
gentoo-40b5831adadd55442b152c2080d8871cb7cfc6e9.tar.bz2
gentoo-40b5831adadd55442b152c2080d8871cb7cfc6e9.zip
net-print/cndrvcups-common-lb: Respect AR, prune static-libs
Closes: https://github.com/gentoo/gentoo/pull/18868 Closes: https://bugs.gentoo.org/762235 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-print/cndrvcups-common-lb/cndrvcups-common-lb-3.70.ebuild')
-rw-r--r--net-print/cndrvcups-common-lb/cndrvcups-common-lb-3.70.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-print/cndrvcups-common-lb/cndrvcups-common-lb-3.70.ebuild b/net-print/cndrvcups-common-lb/cndrvcups-common-lb-3.70.ebuild
index b6566cc425d4..03e2dcc952f1 100644
--- a/net-print/cndrvcups-common-lb/cndrvcups-common-lb-3.70.ebuild
+++ b/net-print/cndrvcups-common-lb/cndrvcups-common-lb-3.70.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools
+inherit autotools toolchain-funcs
MY_PV="$(ver_rs 1- '')"
SOURCES_NAME="linux-UFRII-drv-v${MY_PV}-uken"
@@ -75,7 +75,7 @@ src_configure() {
}
src_compile() {
- change_dir emake
+ change_dir emake AR="$(tc-getAR)"
# Cannot be moved to 'change_dir' as it doesn't need eautoreconf
cd "${S}/c3plmod_ipc" || die
@@ -114,4 +114,6 @@ src_install() {
if [[ "$(get_libdir)" != lib ]] && [[ ${SYMLINK_LIB} = yes ]]; then
dosym "../$(get_libdir)/libc3pl.so" /usr/lib/libc3pl.so
fi
+
+ find "${ED}" -name '*.la' -o -name '*.a' -delete || die
}